crash when attempting to load two non-existent files

VERIFIED DUPLICATE of bug 47927

Status

()

Core
RDF
P3
critical
VERIFIED DUPLICATE of bug 47927
18 years ago
18 years ago

People

(Reporter: Lyle Seaman, Assigned: Chris Waterson)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
latest nightly build.  Unpack and invoke mozilla with shell script, or directly.
 From pull-down menus, select "Debug" then "Viewer Demos" then "#3 Basic
tables".  This fails because the file does not exist.  So far, so good.  Now
choose Debug->Viewer Demos->#4 Simple tables.  Mozilla crashes -- either SIGILL
or SIGSEGV.  No core is generated.  ??!?!  No core?  agh.

Here's some more gory details:

[lws@athabasca package]$ export   LD_LIBRARY_PATH=.
[lws@athabasca package]$ export MOZILLA_FIVE_HOME=.
[lws@athabasca package]$ export      LIBRARY_PATH=.
[lws@athabasca package]$ export        SHLIB_PATH=.
[lws@athabasca package]$ export           LIBPATH=.
[lws@athabasca package]$ export        ADDON_PATH=.
[lws@athabasca package]$ export       MOZ_PROGRAM=./mozilla-bin
[lws@athabasca package]$ export       MOZ_TOOLKIT=
[lws@athabasca package]$ export         moz_debug=0
[lws@athabasca package]$ export      moz_debugger=
[lws@athabasca package]$ strace ./mozilla-bin 2>/tmp/strace
WEBSHELL+ = 1
WEBSHELL+ = 2

-->loadDS(): ds=[xpconnect wrapped nsIRDFDataSource], loaded=true, returning! <--
WEBSHELL+ = 3
Setting content window
*** Pulling out the charset
Loading page specified via openDialog
in SetSecurityButton
Document http://www.mozilla.org/ loaded successfully
WEBSHELL+ = 4
directory.js: Init()
base URL = file:///home/lws/toolsrc/mozilla/package/res/samples/test3.html
Error loading URL resource:///res/samples/test3.html
[lws@athabasca package]$ tail /tmp/strace
gettimeofday({965846772, 697172}, NULL) = 0
poll([{fd=8, events=POLLIN}, {fd=6, events=POLLIN, revents=POLLIN}, {fd=14,
events=POLLIN}], 3, 0) = 1
read(6, "\372", 1)                      = 1
kill(30347, SIGRT_0)                    = 0
read(6, "\372", 1)                      = 1
read(6, "\372", 1)                      = 1
gettimeofday({965846772, 700497}, NULL) = 0
gettimeofday({965846772, 700578}, NULL) = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1

18 years ago
this worksforme with 080909 mozilla build.  Reporter, what build did you test?
(Reporter)

Comment 2

18 years ago
Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; m18) Gecko/20000809

[lws@athabasca package]$ uname -a
Linux athabasca.spinnakernet.com 2.2.12-20 #1 Mon Sep 27 10:40:35 EDT 1999 i686
unknown
[lws@athabasca package]$  id
uid=520(lws) gid=521(lws) groups=521(lws)

Happens if I attempt to load any file that doesn't exist, twice in a row.  RH
6.1.  Files that do exist are fine, naturally.

asa, are you running as root?

Summary: crash when attempting to resolve Viewer Demos under Debug menu → crash when attempting to load two non-existent files

Comment 3

18 years ago
Can't reproduce on Linux 2000-08-10-08.

Comment 4

18 years ago
I can reproduce this every time on my Redhat 6.1 system
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Adding crash keyword to all open crash bugs that don't already have it...
Keywords: crash
(Reporter)

Comment 6

18 years ago
also in
Mozilla M18 Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; m18) Gecko/20000813

RH6.1

Does not occur when running as root.  Asa, Jeffrey, are you running as root?
(Reporter)

Comment 7

18 years ago
Hm  No symbols.  Got a version of librdf and/or libdirectory that have symbols?


Program received signal SIGSEGV, Segmentation fault.
0x0 in ?? ()
(gdb) where
#0  0x0 in ?? ()
#1  0x404fd4cb in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/librdf.so
#2  0x4132ebfa in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/libdirectory.so
#3  0x404fae2a in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/librdf.so
#4  0x4052e848 in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/librdf.so
#5  0x4052cc42 in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/librdf.so
#6  0x4053058b in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/librdf.so
#7  0x404bbdb7 in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/libchrome.so
#8  0x400b651b in PL_HandleEvent ()
   from /home/lws/toolsrc/mozilla/package/./libxpcom.so
#9  0x400b6456 in PL_ProcessPendingEvents ()
   from /home/lws/toolsrc/mozilla/package/./libxpcom.so
#10 0x400b718d in nsEventQueueImpl::ProcessPendingEvents ()
   from /home/lws/toolsrc/mozilla/package/./libxpcom.so
#11 0x405c63bf in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/libwidget_gtk.so
#12 0x405c617d in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/libwidget_gtk.so
#13 0x4076552a in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#14 0x40766be6 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#15 0x407671a1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#16 0x40767341 in g_main_run () from /usr/lib/libglib-1.2.so.0
#17 0x4068f5b9 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#18 0x405c68ac in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/libwidget_gtk.so
#19 0x4039120a in NSGetModule ()
   from /home/lws/toolsrc/mozilla/package/components/libnsappshell.so
#20 0x804dd0a in JS_PushArguments ()
#21 0x804e116 in JS_PushArguments ()
#22 0x402491eb in __libc_start_main (main=0x804e00c <JS_PushArguments+11368>, 
    argc=2, argv=0xbffffa64, init=0x804aec4 <_init>, fini=0x8054544 <_fini>, 
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffa5c)
    at ../sysdeps/generic/libc-start.c:90

Comment 8

18 years ago
over to RDF
Assignee: asa → waterson
Component: Browser-General → RDF
QA Contact: doronr → tever
(Assignee)

Comment 9

18 years ago

*** This bug has been marked as a duplicate of 47927 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
The bug this has been duped against has been fixed, and I'm not seeing this
behavior anymore on Linux build 2000110406. Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.