Mail deleted from preview pane becomes unread in Trash folder

RESOLVED DUPLICATE of bug 545504

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 545504
9 years ago
3 days ago

People

(Reporter: AdamG, Unassigned)

Tracking

({regression})

x86
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

Using Thunderbird 3b2, upon reading mail in the 3-pane view, after deleting it (whether by the toolbar button or the delete key) it reappears as unread in the trash folder.  

I have the following settings:
1.  Mark messages as read immediately in preview pane (also reproducible with a 1 second delay until marking as read)
2.  Move deleted messages to trash folder
3.  Using IMAP servers (2 different accounts, same behaviour)

This happens only in the TB3 beta, does not do it on TB2.  It also sometimes will eventually mark some of the older messages as deleted, but the most recently deleted messages always remain marked unread in the trash folder instead of remaining read.

Reproducible: Always

Steps to Reproduce:
1. Use preview pane to read messages
2. Delete messages, which moves it to the Trash folder on the same server
3. Go to trash folder, messages are now marked as unread
Actual Results:  
Messages that were previously marked as read became unread in trash folder.

Expected Results:  
Messages should remain marked as read.
(Reporter)

Updated

9 years ago
Summary: Mail deleted from preview pane after reading becomes unread in Trash folder → Mail deleted from preview pane becomes unread in Trash folder
Patch for Bug 211439(fixed on 2008-10-26) won't work any more or won't work when IMAP? (See Bug 475911 Comment #5). Sequence of "uid xxx store flag \Seen" and "uid xxx copy Trash" was reverted? Bug 470650 is relevant? Recent flag is relevant? 
> RFC 3501
>  6.4.7.  COPY Command
>(snip)
>     The COPY command copies the specified message(s) to the end of the
>     specified destination mailbox.  The flags and internal date of the
>     message(s) SHOULD be preserved, and the Recent flag SHOULD be set,
>     in the copy.

Get IMAP log and check IMAP flow.
> Getting log : See Bug 402793 Comment #1
> IMAP command/response : http://www.faqs.org/rfcs/rfc3501.html
(Reporter)

Comment 2

9 years ago
Well, if this is the desired result, then why is that not the result in previous versions of TB or any other email client I've ever used?  Or is \Recent bein interpreted the same way as \Seen in the beta?

The IMAP log was incredibly long and seemed to only contain the server responses.  Will try to generate another one - it's very difficult with the large mailboxes on my servers.

Either way, the functionality of deleting messages has changed from TB 2.x to TB 3b2 (didn't try the alphas or beta 1, so I don't know when it crept in).
(In reply to comment #2)
> The IMAP log was incredibly long and seemed to only contain the server responses.

Get log with small/single mail folder access only.
(I think "new profile with single IMAP account only" is better for testing)
 - Disable automatic mail check options.
 - Disable Auto-Sync of all IMAP accounts, Disable Gloda (auto indexing)
 - Create mail folder, copy several mails to folder, mark some of them Unread.
 - Restart Tb, view the folder only, mark as Read & Delete a mail
You can probably see flow of uid store flag, uid copy etc.
Search such flow around your mark unread/delete operation in the incredibly long log file.

Comment 4

9 years ago
Haven't seen this. AdamG: to move this forward we need an imap log, per about comments.
Keywords: regression
(Reporter)

Comment 5

9 years ago
Created attachment 371327 [details]
Test case for deleted mesasges appearing as "new"

I've created a test profile and folder as requested, and here is the log output (trimmed of the irrelevant stuff).  At first glance, it appears that the commands are working correctly, but TB still shows these messages as new/unread when changing to the trash folder.  
I think perhaps this is a UI issue or not having the \Seen flag override the \Recent flag when displaying the message lines?
(Reporter)

Comment 6

9 years ago
Playing around with this a touch more, I'm more convinced it's a UI issue.  If I go to the Trash folder with recently deleted messages, it pretty reliably shows them as new.  However, if I do nothing other than switch to another folder and then back to the Trash folder, the "new" indicator is turned off.

So it seems that the status is not being changed from "Read" to "Unread" (i.e. via removing the \Seen flag), but TB is now displaying messages with the \Recent flag as "Unread", even if the \Seen flag is present.

Do you all concur?

Updated

8 years ago
Whiteboard: dupme
Version: unspecified → 3.0

Comment 7

7 years ago
Adamg, do you still see this in version 3.1?

(In reply to comment #6)
> Playing around with this a touch more, I'm more convinced it's a UI issue.  If
> I go to the Trash folder with recently deleted messages, it pretty reliably
> shows them as new.  However, if I do nothing other than switch to another
> folder and then back to the Trash folder, the "new" indicator is turned off.
> 
> So it seems that the status is not being changed from "Read" to "Unread" (i.e.
> via removing the \Seen flag), but TB is now displaying messages with the
> \Recent flag as "Unread", even if the \Seen flag is present.
> 
> Do you all concur?
Whiteboard: dupme → [closeme 2011-04-11]dupeme
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Updated

3 days ago
Resolution: INCOMPLETE → DUPLICATE
Whiteboard: [closeme 2011-04-11]dupeme
Duplicate of bug: 545504
You need to log in before you can comment on or make changes to this bug.