Firefox incorrectly displaying arabic-indic digits in webpage, webpage inputs and so on

RESOLVED DUPLICATE of bug 441782

Status

()

Core
Internationalization
--
major
RESOLVED DUPLICATE of bug 441782
9 years ago
9 years ago

People

(Reporter: W.M., Assigned: Ehsan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ar; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ar; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

Firefox for WinXP is not correctly display arabic-indic digits in webpage layout, webpage inputs and so on. But Internet Explorer automatically translate typed 1,2,3 to their native representation in unicode ۱ ۲ ۳.

This can be checked on local Farsi windows and may be on other localized versions.

Reproducible: Always

Steps to Reproduce:
1. Have Localized windows XP (f.e. - Farsi)
2. Go to http://president.ir/fa/ f.e.
3. In Left corner try to type some digits
Actual Results:  
You will see digits in ASCII

Expected Results:  
You should see arabic-indic digits in UNICODE
(Reporter)

Comment 1

9 years ago
Created attachment 366558 [details]
Screenshot FF

FireFox does not display arabic-indic digits in input and calendar/clock
(Reporter)

Comment 2

9 years ago
Created attachment 366560 [details]
Screenshot IE

Internet Explorer handles arabic-indic digits well both in input and in clock.
Assignee: nobody → smontagu
Component: General → Internationalization
Product: Firefox → Core
QA Contact: general → i18n
Probably dupe of bug 441782, passing to Ehsan for triage.
Assignee: smontagu → ehsan.akhgari
(Assignee)

Comment 4

9 years ago
Yes, a dupe of bug 441782, indeed.

Some information which can help the reporter:

The bidi.numeral preference (which allows you to set how Mozilla is supposed to treat numbers in web pages, etc.) was broken in Firefox 3.0, but it's fixed in Firefox 3.1 Beta 3 which will be released shortly.  If you need this behavior, I suggest you upgrade to that version once it's released.

Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441782
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Yes, a dupe of bug 441782, indeed.
> 
> Some information which can help the reporter:
> 
> The bidi.numeral preference (which allows you to set how Mozilla is supposed to
> treat numbers in web pages, etc.) was broken in Firefox 3.0, but it's fixed in
> Firefox 3.1 Beta 3 which will be released shortly.  If you need this behavior,
> I suggest you upgrade to that version once it's released.
> 
> Thanks!
> 
> *** This bug has been marked as a duplicate of bug 441782 ***

Thanks a lot, Ehsan! Where can I find information about bidi.numerals? Will it be set to right value on localized version of FireFox by default, or manual set up will be needed?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

9 years ago
sorry, firefox glitch :) Change status back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441782
(Assignee)

Comment 7

9 years ago
(In reply to comment #5)
> Thanks a lot, Ehsan! Where can I find information about bidi.numerals? Will it

<http://kb.mozillazine.org/About:config_entries#Bidi..2A>

Also, please note that in Firefox 3.1, two more values have been added which are not yet documented (and may be interesting for you if you read Persian content more than Arabic content):

5: Persian context numerals (like 1 and 2, but using Persian digits)
6: Persian numerals (like 4, but using Persian digits everywhere)

> be set to right value on localized version of FireFox by default, or manual set
> up will be needed?

We don't (yet) set bidi.numeral in the Persian localization, but I'm not sure about other locales.  Anyway, it's easy to check, just open about:config and see if bidi.numeral has a value other than 0 set.
See also bug 151374
You need to log in before you can comment on or make changes to this bug.