[4.xP]FONT FACE element effects other elements - in this case main body content gets moved down the page

VERIFIED FIXED in M6

Status

()

Core
HTML: Parser
P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Christine Hoffman, Assigned: rickg)

Tracking

Trunk
All
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using 4/8 build on Win 95, Win NT, Win 98, Mac8.5 and Linux.

This is an isolated case from the URL above:

<html>
<head>
<title>stuttgart</title>
</head>
<body>
<table border="1" cellpadding="0" cellspacing="0" width="100%">
<font face="Arial">
	<tr>
		<td align=center>text 1<BR>text 2
		</td>
    		<td>text 3
		</td>
    		<td>text 4
			<table border="1" cellpadding="0" cellspacing="0"
width="100%">
      				<tr>
        				<td >text 5<br><br>
					</td>
				       <td>text 6
					</td>
      				</tr>
      			</table>
    		</td>
  	</tr>
  	<tr>
    		<td>text 7<BR>
		</td>
    		<td BGCOLOR="#AAAAFF">text 8<BR>
		</td>
  	</tr>
  	<tr>
    		<td>
		</td>
  	</tr>
  	<tr>
    		<td>text 9
		</td>
  	</tr>
</table>
</body>
</html>

Gecko (cross platform): Page does not display correctly with FONT FACE element
inserted. If you take it out, page is okay.

Comm 4.51, IE: Content displays properly

This may be a duplicate of another bug I wrote up, #4814.

Updated

19 years ago
Assignee: troy → rickg
Component: Layout → Parser

Comment 1

19 years ago
Rick, this is probably known, but what's happening is that the outer table's
content is just plain text and has no rows or cells. Here's a dump of the
content model:

html refcount=3<
  head refcount=2<
    title refcount=2<
      Text refcount=2<stuttgart>
    >
  >
  body refcount=3<
    Text refcount=3<\n>
    table border=1 cellpadding=0 cellspacing=0 width=100% refcount=4<
    >
    font face=Arial refcount=9<
      Text refcount=3<\n        \n                text 1>
      br refcount=3<>
      Text refcount=3<text 2\n                \n                text 3\n
        \n                text 4\n                        >
      table border=1 cellpadding=0 cellspacing=0 width=100% refcount=7<
        tbody refcount=3<
          tr refcount=3<
            td refcount=4<
              Text refcount=3<text 5>
              br refcount=3<>
              br refcount=3<>
              Text refcount=3<\n                                        >
            >
            td refcount=4<
              Text refcount=3<text 6\n                                        >
            >
          >
        >
      >
      Text refcount=3<\n                \n        \n        \n                te
xt 7>
      br refcount=3<>
      Text refcount=3<\n                \n                text 8>
      br refcount=3<>
      Text refcount=3<\n                \n        \n        \n                \n
                   \n        \n        \n                text 9\n
 \n        \n\n\n\n>
    >
  >
>
(Assignee)

Comment 2

19 years ago
Corrected by changes to parsing engine.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Fixed in 5/17 Build.
You need to log in before you can comment on or make changes to this bug.