view in wrong place when scrollbar goes away

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: mozilla, Assigned: eric)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-3 i686; en-US; m18) Gecko/20000809
BuildID:    2000080910

When I change the font size from 16 to 12 after scrolling to the bottom of the
mozilla page, the layout engine relays the page. Since the page is now small
enough to not need a scrollbar ,the scroll bar goes away. But Mozilla forgets to
scroll up to the _top_ of the page, so the top part of the page is chopped off
with no apparent way to get back to it. (You can scroll up by selecting text and
moving the mosue up off the top of the browser window, forcing it to scroll.)

Reproducible: Always
Steps to Reproduce:
1. load a web page taller than the screen, with a font setting in the prefs
that's "large"
2. scroll down
3.change the prefs to use a smaller font size, so that the page fits in one screen.

Actual Results:  It messes up, as described in the description.

Expected Results:  It should scroll to the top of the page, since all of the
page can fit in the window.

I will check this on the Mac build of mozilla later tonight.
(Reporter)

Comment 1

18 years ago
I just checked with 2000080908 on the Mac, and this problem is happening as well. 

Can someone try it in Windows?

Although at 1024x768 I have to remove both toolbars to see this bug on 
mozilla.org (it would probably be more obvious on some other pages) it is there 
under Windows - WinNT4 0000819. Confirming, nsbeta3. Another one which needs 
fixing if we aren't all to look foolish.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Whiteboard: nsbeta3.
This is a more general problem with what happens when scrollbars go away.  I'll
attach a testcase that shows a DOM example:
 * load the testcase
 * scroll to the bottom
 * click the button  - you should now see the button at the top of the page, but
you have to hit PgUp to see it.

Assigning to evaughan to take a look.
Assignee: clayton → evaughan
Keywords: nsbeta3
Summary: change font size in prefs; layout removes scrollbar and doesn't scroll to top of page → view in wrong place when scrollbar goes away
Whiteboard: nsbeta3.

Comment 5

18 years ago
nsbeta3-/future. No time left for obscure edge cases like this.
Whiteboard: [nsbeta3-]
Target Milestone: --- → Future
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
*** Bug 47239 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
WORKSFORME, build 2001-08-09-04 on Windows 98 SE.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.