Last Comment Bug 482605 - Update AMO on Mar 12
: Update AMO on Mar 12
Status: VERIFIED FIXED
:
Product: Infrastructure & Operations
Classification: Other
Component: WebOps: Other (show other bugs)
: other
: All Other
: -- blocker (vote)
: ---
Assigned To: Aravind Gottipati [:aravind]
: matthew zeier [:mrz]
Mentors:
: 483162 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 14:29 PDT by Wil Clouser [:clouserw]
Modified: 2013-10-09 10:29 PDT (History)
8 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---
Cab Review: ServiceNow Change Request (use flag)


Attachments

Description Wil Clouser [:clouserw] 2009-03-10 14:29:28 PDT
Please update AMO on 3/12.  Steps:

1) Run all the database changes in To be run in production -> 5.0.3 on https://wiki.mozilla.org/Update:Developers/Database_Changes#5.0.3

2) `svn up` addons.mozilla.org

I still need to tag the site so this bug is only serving as advanced notice. Please wait for an update from me in the bug before updating. Thanks.
Comment 1 Stephen Donner [:stephend] - PTO; back on 5/28 2009-03-12 12:49:39 PDT
r=stephend for QA.
Comment 2 Wil Clouser [:clouserw] 2009-03-12 13:04:00 PDT
This is tagged in r23222 to prod external.  a=clouserw to proceed.

I'm going to be away tonight from 6-8pm california time.  I don't expect anything to go wrong, but fyi.
Comment 3 Aravind Gottipati [:aravind] 2009-03-12 20:10:52 PDT
You said the tag was 23222, but the update only pulled this.

A    site/app/views/elements/developers/editors_review_history_item.thtml
U    site/app/views/elements/developers/sidebar.thtml
U    site/app/views/elements/developers/editbox.thtml
U    site/app/views/elements/developers/rolecheck.thtml
U    site/app/views/elements/developers/translationbox.thtml
U    site/cake/libs/model/datasources/dbo_source.php
Updated external to revision 23221.


Fetching external item into 'bin'
U    bin/compatibility_report.php
U    bin/maintenance.php
Updated external to revision 23221.


Fetching external item into 'site/vendors/product-details'
U    site/vendors/product-details/productDetails.class.php
U    site/vendors/product-details/history/firefoxHistory.class.php
U    site/vendors/product-details/firefoxDetails.class.php
U    site/vendors/product-details/thunderbirdDetails.class.php
Updated external to revision 23221.

Updated to revision 23245.
[root@mradm02 addons.mozilla.org-remora]# 

Not sure if that matters...

In any case, db changes done, sites updated.  Content should be live in about 20 minutes.
Comment 4 Wil Clouser [:clouserw] 2009-03-12 20:13:03 PDT
Can you do an SVN status and an SVN info on it then?  It should have updated a lot more than that
Comment 5 Wil Clouser [:clouserw] 2009-03-12 20:19:14 PDT
The first list should have started with "Fetching external item into 'prodexternal/site'" - are you sure you didn't copy just the bottom of the list?

I'm reopening because if only have the files got pushed the site will be broken.
Comment 6 Aravind Gottipati [:aravind] 2009-03-12 21:40:35 PDT
Should be all good now..
Comment 7 Wil Clouser [:clouserw] 2009-03-12 22:19:25 PDT
It's been over 2 hours since the update and there are no changes visible
Comment 8 Aravind Gottipati [:aravind] 2009-03-12 23:46:48 PDT
Sorry anout the wait.  I had no idea that you had problems with it until the bug paged me.  The problem turned out to be a stuck git lock preventing the updates from being pushed to the webheads.  We will soon have a nagios monitor to check for this stuff.
Comment 9 Stephen Donner [:stephend] - PTO; back on 5/28 2009-03-12 23:48:12 PDT
Verified FIXED (deployed); "Share this" functionality is showing up, and https://addons.mozilla.org/en-US/firefox/blog, which we removed, is now a 404 as expected.
Comment 10 Nick Nguyen [:osunick] 2009-03-13 00:27:44 PDT
We're seeing all sorts of issues, for instance the editor url: https://addons.mozilla.org/en-US/editors returns a 404.
Comment 11 Aravind Gottipati [:aravind] 2009-03-13 02:03:07 PDT
*** Bug 483162 has been marked as a duplicate of this bug. ***
Comment 12 Michael Morgan [:morgamic] 2009-03-13 02:45:27 PDT
For any AMO updates in prod, we need to add instructions on how to clear app/tmp/cache/ files to prevent cake from having incorrectly cached output after any update that changes routes or adds/removes views.
Comment 13 Aravind Gottipati [:aravind] 2009-03-13 02:52:41 PDT
After deleting these file, folks have pronounced this to be working.
Comment 14 Stephen Donner [:stephend] - PTO; back on 5/28 2009-03-13 02:56:59 PDT
Verified FIXED (again, and for real this time, I trust).

Even the "Share this" fallout of yore seems fixed both when logged in and out...

Note You need to log in before you can comment on or make changes to this bug.