Closed Bug 482718 Opened 12 years ago Closed 12 years ago

Remove toolkit history remnants in libxul build, left by bug 383833

Categories

(Firefox Build System :: General, defect)

1.9.1 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: fixed1.9.1)

Attachments

(1 file)

Bug 383833 removed toolkit/components/history from the build but missed removing the libxul library inclusions in toolkit/library.

This means if your app builds with mork, you're not going to be able to build with --enable-libxul.
Attached patch The fixSplinter Review
Removes the unnecessary items.
Attachment #367034 - Flags: review?
Attachment #367034 - Flags: review? → review?(ted.mielczarek)
Attachment #367034 - Flags: review?(ted.mielczarek) → review+
Checked in: http://hg.mozilla.org/mozilla-central/rev/7c6ef292bca3
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Comment on attachment 367034 [details] [diff] [review]
The fix

Requesting 1.9.1 branch approval. Build config patch only so should be low risk.

If anyone is trying to build a libxul app with mork enabled, then they will want this patch.
Attachment #367034 - Flags: approval1.9.1?
Duplicate of this bug: 487878
Comment on attachment 367034 [details] [diff] [review]
The fix

a191=beltzner
Attachment #367034 - Flags: approval1.9.1? → approval1.9.1+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.