login button misplaced on Juniper Networks support site

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: Robert Sayre, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---
Bug Flags:
wanted1.9.1 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
works in Fx2, but not Fx3.0 or Fx3.1. Also works in Safari 4.
Could use a testcase and/or regression dates.
Keywords: qawanted
Looks identical to me in Minefield, IE7 and Safari 4 on Windows.

Updated

9 years ago
Keywords: qawanted → regressionwindow-wanted, testcase-wanted
OK, this regressed between 2007-05-23-04 and 2007-05-24-04 on Mac.  Bonsai range:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-05-23+04&maxdate=2007-05-24+04&cvsroot=%2Fcvsroot

Right at the end of that is mac native theming being enabled for HTML.  Setting "-moz-appearance:none" on the two text inputs via DOM inspector fixes the layout over here.

The relevant style the page has on the input is: "width: 121px".  But the page is in standards mode, so text inputs are using content-box sizing, not border-box.  And native theming of text inputs on mac adds quite a bit of padding; a lot more than non-themed controls have.  So the box width ends up being 121px + border + padding, is too big for the space the page has allotted for it (which is presumably based on 121px + windows native theme padding), and the controls wrap to the next line.

I still think that the extra padding the mac native theme produces is a bug, certainly for constrained-width inputs, precisely because of cases like this.
Assignee: nobody → joshmoz
Blocks: 175279
Component: Layout → Widget: Cocoa
Keywords: regressionwindow-wanted, testcase-wanted → qawanted
QA Contact: layout → cocoa
Keywords: qawanted
Oh, and naturally setting "-moz-box-sizing: border-box" also fixes the layout.
Flags: wanted1.9.1?
Assignee: joshmoz → mstange

Comment 5

4 years ago
Clearly this isn't being worked on, and the site doesn't appear to have any problems now. It has probably also changed quite a bit since this was reported.
Assignee: mstange → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.