JarMaker.py unittests don't cause "make check" to fail

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: ted, Assigned: Pike)

Tracking

({fixed1.9.1})

Trunk
fixed1.9.1
Points:
---
Bug Flags:
blocking1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I noticed that the JarMaker.py unittests are failing on my x86-64 Linux machine, but "make check" was still succeeding. This is bad, they should make it fail.
(Assignee)

Comment 1

9 years ago
Taking.

Is just calling

  false;

portable?

And the failure on -64 was that dash doesn't know about ==, but only =. I'll fix that as I go.
Assignee: nobody → l10n
Status: NEW → ASSIGNED
(Assignee)

Comment 2

9 years ago
Created attachment 367044 [details] [diff] [review]
use = instead of ==, and false to fail on tests, with better debug output
Attachment #367044 - Flags: review?(ted.mielczarek)
(Assignee)

Updated

9 years ago
Duplicate of this bug: 483432
(Reporter)

Comment 4

9 years ago
Comment on attachment 367044 [details] [diff] [review]
use = instead of ==, and false to fail on tests, with better debug output

This WFM on Ubuntu. Thanks!
Attachment #367044 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/45fc547f59ff, marking FIXED.

I guess that we want this on 1.9.1, too.
Flags: blocking1.9.1?
(Reporter)

Comment 6

9 years ago
Not blocking, but we should take it anyway.
Flags: blocking1.9.1? → blocking1.9.1-
(Reporter)

Comment 7

9 years ago
Comment on attachment 367044 [details] [diff] [review]
use = instead of ==, and false to fail on tests, with better debug output

a1.9.1+ once it bakes. (green unittests on all platforms should be enough.)
Attachment #367044 - Flags: approval1.9.1+
(Assignee)

Comment 8

9 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/00921829ac6c, fixed1.9.1, too.
Keywords: fixed1.9.1
(Reporter)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Depends on: 490358
You need to log in before you can comment on or make changes to this bug.