Closed Bug 482828 Opened 13 years ago Closed 13 years ago

sporadic zero-length MSF files after a message is moved from the Inbox to a mail file

Categories

(MailNews Core :: Backend, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: davofanmail, Unassigned)

Details

(Keywords: regression, Whiteboard: regressed eduora-b3/Ttb-a1pre<~2008-02-22> and eu-b4/tb-b1pre<2008-11-04>)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Eudora 8.0.0b5 which is T'Bird Pre1

In using Eudora/TBird for the last couple of releases, every few hours at least one of my active mail files gets a zero-length msf file, which triggers an index rebuild (which triggers another bug which I won't go into here).

I haven't figured out under what conditions msf files get truncated @ 0 bytes, but it seems to happen only with mail files that are fairly frequently written to (by moving messages in/out).

This is a regression from over the last few months, and I suspect it has something to do with a file lock not getting released.

Reproducible: Always

Steps to Reproduce:
1.Use T'bird
2.Move messages around among mail files (particularly if from an Inbox)
3.
Actual Results:  
Occasionally, msf file of target file is zero, triggering a spurious index rebuild

Expected Results:  
MSF file would always be updated by message moves, and would never be of length 0.

May not be related, but "junk" folders *never* seem to have msf files.  This is true even if I create a junk.msf file -- it will get used properly for a while, but then some part of T'bird will eventually delete the junk.msf file, meaning *every* view of the junk folder triggers a summary file rebuild.
Discovered that sometimes Eudora/T'bird is deleting a target folder's MSF file outright when a message is moved (drag/drop) from an Inbox.

This symptom occurance patterns seem to be:
 - junk.msf often deleted by operation of junk filter or manual "set to junk status" actions
 - targetfile.msf sometimes deleted or truncated by either D-N-D or explicit moves from the message's context menu ("move-to")
 - targetfile.msf *never* deleted or corrupted by filters moving messages from an Inbox
Assignee: nobody → mozilla-bugs
Product: Thunderbird → Penelope
QA Contact: general → general
Version: unspecified → Trunk
It would be great if there were a newer Eudora based on a newer thunderbird because this could be an issue already recently resolved in thunderbird. 

Or a way for you to narrow down the regression range of when the problem started.
Severity: normal → major
Problem started when I moved to Eudora beta 4, which I think was based on pre-3 T'bird.  

Using the newest version of Eudora available.  

Please advise:  would it be safe for me to uninstall Eudora and run latest T'Bird, or would that goof up mail files and/or Eudora configuration / prefs files?
the problem sometimes occurs a few seconds *after* a message is moved from the Inbox to a mail file.  Perhaps the move-message activity triggers a re-index of the msf file right after it's appended to by the message move?

Trying to measure the patterns, but I'm working with basically zero diagnostics here.
(In reply to comment #3)
> Please advise:  would it be safe for me to uninstall Eudora and run latest
> T'Bird, or would that goof up mail files and/or Eudora configuration / prefs
> files?

In general it's OK to move between TB 3 and Eudora 8, but there's some issues with mailbox columns and toolbars.
Eudora changes those, and it will be reflected when the user goes back to TB.
As you indicate that this problem appears in Thunderbird as well I am going to assign this to Thunderbird.

Matt
Assignee: mozilla-bugs → nobody
Product: Penelope → Thunderbird
QA Contact: general → general
(In reply to comment #3)
> Problem started when I moved to Eudora beta 4, which I think was based on pre-3
> T'bird.  

so regressed between eduora-b3/Ttb-a1pre<~2008-02-22> and eu-b4/tb-b1pre<2008-11-04>

Unfortunately one can't query bugzilla for regression ranges :(

if its a reported bug and it is fixed, some pot shots include
 Bug 437886 -  nsIMsgDBService::openFolderDB unusable from JavaScript (which isn't a regression bug)

or one of these https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&long_desc_type=anywords&long_desc=msf+index+.msf+indexes+rebuild&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&product=MailNews+Core&product=Thunderbird&product=Toolkit&version=Trunk&version=Trunk&resolution=FIXED&resolution=DUPLICATE&resolution=---&bug_severity=blocker&bug_severity=critical&bug_severity=major&emailreporter1=1&emailtype1=substring&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=2008-02-22&chfieldto=2008-11-04&chfield=[Bug+creation]&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=resolution&type0-0-0=changedafter&value0-0-0=2008-11-04
Component: General → Backend
Keywords: regression
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Summary: sporadic zero-length MSF files → sporadic zero-length MSF files after a message is moved from the Inbox to a mail file
Whiteboard: regressed eduora-b3/Ttb-a1pre<~2008-02-22> and eu-b4/tb-b1pre<2008-11-04>
rkent fixed a bug where moving a message would result in an out of date summary file. He fixed that before b2, iirc.
(In reply to comment #8)
> rkent fixed a bug where moving a message would result in an out of date summary
> file. He fixed that before b2, iirc.

yeah, I forgot to cc: rkent
note that this occurs with POP inboxes, whether or not indexing is turned on.
This problem has disappeared for me upon upgrading to Eudora b6 (Tbird pre2).  AFAIC, this one can be closed.  But that's just me.
(In reply to comment #11)
> This problem has disappeared for me upon upgrading to Eudora b6 (Tbird pre2). 
> AFAIC, this one can be closed.  But that's just me.

WFM based on your comment.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.