about:config doesn't focus on "Filter" box unless a new tab is used - regression

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: duncan.loveday, Unassigned)

Tracking

({regression, testcase})

3.6 Branch
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090107 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090107 Minefield/3.2a1pre

When loading about:config in a new tab, focus is set on the "Filter" allowing one to start typing immediately. However when loading about:config in a previously-used tab then this does not occur. You have to click in the "Filter" field before typing.

On Firefox 3.0.7, focus is always set on the "Filter" field when about:config is loaded so this is a regression.

Reproducible: Always

Steps to Reproduce:
1. Press ctrl-T to open a new tab, type "about:config" and press enter. Note that focus is set on the "Filter field" and you can type in the field right away.
2. Press ctrl-T to open another new tab. In this tab enter "about:blank" and press enter.
3. In this second tab, type "about:config" and press enter. Note that focus is NOT set on the "Filter field" and you can NOT type in the field until you clikc in it.
Actual Results:  
In step 3, focus is "nowhere"

Expected Results:  
In step 3, focus should be in the "Filter" field as in step 1.

Bug does not occur on Fx 3.0.7
(Reporter)

Comment 1

10 years ago
Actually just now I couldn't reproduce this using about:blank in step 2, however using bugzilla.mozilla.org I could. Maybe there's a timing dependency.
Keywords: regression, testcase
Your using an rather old build at this point from Jan 7.

Using the latest build (hourly) I can't repo this problem.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090311
Minefield/3.2a1pre Firefox/3.0.4 ID:20090311125310
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Your using an rather old build at this point from Jan 7.
> 
Oh yes, so I am. But I can reproduce on this build

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090307 Minefield/3.2a1pre

Will get the latest nightly and try.

To be clear, the steps are

1) New tab
2) Load bugzilla.mozilla.org
3) Load about:config
(Reporter)

Comment 4

10 years ago
I can also reproduce with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090312 Minefield/3.2a1pre
I can't reproduce on this very bugzilla page, no matter how hard I try.  Duncan: how about you?
(Reporter)

Comment 6

8 years ago
I can't reproduce this now on Fx 3.0, 3.6 or 4.x trunk.

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 7

7 years ago
Resolving WORKSFORME per comment 6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.