If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

have to remove classid, codebase from object to play flash

RESOLVED DUPLICATE of bug 153288

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 153288
9 years ago
8 years ago

People

(Reporter: matt wilkie, Unassigned)

Tracking

3.0 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

This one particular Firefox install will not play flash unless the classid and codebase attributes are removed from the object tag. I've tested five other computers with Firefox installed so far and they all work with the default attributes. Tested Browser versions ranged from 3.05 to 3.07, on both 32bit and 64bit XP prodessional.

Reproducible: Always

Steps to Reproduce:
1. visit http://damowmow.com/playground/demos/flash/001.html

Actual Results:  
page is empty

Expected Results:  
expected to see a short animation extorting the benefits of macromedia flash.

This works on the problem machine:

  <p>
   <object width="300" height="120">
    <param name="movie" value="http://www.macromedia.com/shockwave/download/triggerpages_mmcom/flash.swf"> 
    <param name="quality" value="high">
    <param name="bgcolor" value="#FFFFFF">
    <!--[if !IE]> <-->
    <object data="http://www.macromedia.com/shockwave/download/triggerpages_mmcom/flash.swf" type="application/x-shockwave-flash" width="300" height="120">
     <param name="quality" value="high">
     <param name="bgcolor" value="#FFFFFF">
     <param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer">
     FAIL (the browser should render some flash content, not this).
    </object>
    <!--> <![endif]-->
   </object>
  </p>
 
This doesn't:

  <p>
   <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" width="300" height="120">
    <param name="movie" value="http://www.macromedia.com/shockwave/download/triggerpages_mmcom/flash.swf"> 
    <param name="quality" value="high">
    <param name="bgcolor" value="#FFFFFF">
    <!--[if !IE]> <-->
    <object data="http://www.macromedia.com/shockwave/download/triggerpages_mmcom/flash.swf" type="application/x-shockwave-flash" width="300" height="120">
     <param name="quality" value="high">
     <param name="bgcolor" value="#FFFFFF">
     <param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer">
     FAIL (the browser should render some flash content, not this).
    </object>
    <!--> <![endif]-->
   </object>
  </p>
 
I've disabled all extensions and plugins, rebooted, cleared cache, removed cookies for the flash sites I'm trying to look at, and removed browsing history.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

9 years ago
Portable firefox 3.07 on the problem machine works just fine. Apparently something in the profile is messing flash up; any suggestions as to how to find and remove the offending wotsit would be greatly appreciated. thanks.

Updated

8 years ago
Blocks: 407918
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 153288
You need to log in before you can comment on or make changes to this bug.