Down arrow/"end"-key in last line produces additional line feed

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: 1stein.alias.manuel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.7) Gecko/2009030423 Ubuntu/8.04 (hardy) Firefox/3.0.7
Build Identifier: Version 2.0.0.19 (20090105)

When I start a new mail and I go to the last line with the down-arrow oder end keys, a new line is created immediately before I write the next character.

I could reproduce this in the last few versions of Thunderbird 2 on Ubuntu 8.04 with amd64 architecture, and, if my memory isn't playing tricks on me, also earlier on Windows XP.

Reproduction is always possible at the first time I try it in a new Message Compose Window, but fails sometimes when I try it a second time in the same window. When I open a new window, the bug occurs again, however.

Reproducible: Always

Steps to Reproduce:
1. Open a new Message Compose Window
2. Scroll to the last line using the keys Down, Ctrl-Down, End or/and Ctrl-End
3. Write an arbitrary character
Actual Results:  
The window does not produce the character, but newline and the character.

Expected Results:  
Well, only the character itself ;D

Comment 1

9 years ago
Using the latest nightly of tb3, Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1pre) Gecko/20090607 Shredder/3.0b3pre   running on Ubuntu Jaunty

I can't reproduce this as described, however if I switch to Plain Text composition and have my Signature enabled then it seems an additional newline appears at the end (which does not appear in HTML composition) - but I can move to the extra newline with the mouse. Is this the same as your problem? If not, this bug may have been fixed in the latest nightly
(Reporter)

Comment 2

9 years ago
I can reproduce this bug still, but only if I answer a mail. Clicking on the "New Mail" button doesn't reproduce it. The answer button still does, however.

I don't have a signature in use, so the problem you described ist not the same as mine.

Comment 3

8 years ago
Windows XP SP3 fully patched
Thunderbird 2.0.0.23 (20090812)  (check for new updates returns nothing)

I'm assuming I'm in HTML mode, as the pull down for style, font, etc are available.

I was able to reproduce it regularly this way:

<ctrl-n>  (A new email window pops up...)
<tab>
<tab>   (so now the cursor is in the text editting window)
adsf    (type the letters 'adsf ', note the space after adsf, it must be there.)
<down-arrow>   (press the down arrow)
adsf    (type the letters 'adsf ', this is put onto a new line for me, though no <return> was ever typed.)
<down-arrow>   (press the down arrow)
adsf    (type the letters 'adsf ', this is put onto a new line for me, though no <return> was ever typed.)
[ repeat, ad nauseum ]
WFM

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100623 Lightning/1.0b2pre Lanikai/3.1.1pre ID:20100623034626

1stein.alias.manuel and Ken, could you reproduce the issue also with latest TB 3.0.x?
Whiteboard: closeme 2010-07-05

Comment 5

8 years ago
I cannot reproduce this particular issue.  (html emails are a bugaboo, but not this issue.)
(Reporter)

Comment 6

8 years ago
I too cannot reproduce it under 3.0.4. Seems to be fixed...
One bug fixed, ninetynine to go :D
WFM per comment #5 and comment #6 (reporter).

Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme 2010-07-05
You need to log in before you can comment on or make changes to this bug.