invited events should be uneditable

RESOLVED DUPLICATE of bug 451380

Status

Calendar
Lightning Only
RESOLVED DUPLICATE of bug 451380
10 years ago
9 years ago

People

(Reporter: Robert Chien, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: 0.9

I just noticed that invited events are not completely locked when they should be. When I hover my mouse over them, they don't show top and bottom bars where I can change the duration, but I can move them to another timeslot. If I highlight the event, and click on the title, I can change the title.

These changes are lost once I reload. But they should not be modifiable, right?

Reproducible: Always

Steps to Reproduce:
1. Hover mouse over invited event
2. Drag event to another timeslot
3. Click on title to change
Actual Results:  
Changes can be made to event by invitee, but they are lost upon reload.

Expected Results:  
Invitee cannot make changes.
Depends. Other users request the complete opposite. For example Bug 451380 requests that all aspects of an accepted invitation should be changeable. Nevertheless the current implementation seems faulty in some aspects.
(Reporter)

Comment 2

10 years ago
You're right. I should mention that I'm using a WCAP calendar. In Calendar Express (the other WCAP client), invited events are non-editable, hence I was surprised they're editable in Lightning.

The bottomline, I guess, is that whichever way Lightning decides to go, it should be consistent with other clients, as well as with itself across reloads.
Whiteboard: [needs decision]
Lets go with the behavior in bug 451380 in the long run.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451380
Whiteboard: [needs decision]
You need to log in before you can comment on or make changes to this bug.