Cursor losing "pointer" status, as defined by CSS, after click

RESOLVED DUPLICATE of bug 445567

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 445567
9 years ago
9 years ago

People

(Reporter: Rory Reiff, Unassigned)

Tracking

({regression})

1.9.0 Branch
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7

I am styling my cursor to be "pointer" over certain areas of my site, namely a dynamic navigation that consists of shown and hidden ul and li elements. Even though I have specified #navigation { cursor: pointer; } for the entire section, as well as #navigation:hover { cursor: pointer; } and even adding * to make sure I am covering all children, the pointer still reverts to an arrow after clicking once. You have move the mouse away and back again to see the pointer.

Reproducible: Always

Steps to Reproduce:
1. hover over the brown navigation on the left. see the pointer being generated by CSS
2. click on navigational element in same column. See cursor revert to arrow
3. move away and back to see pointer again
Actual Results:  
cursor loses pointer style after clicking

Expected Results:  
cursor should maintain pointer style since I am still hovering over section with applied css styling
(Reporter)

Updated

9 years ago
Keywords: regression
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090311 Minefield/3.2a1pre

I see the described behavior indeed with Firefox 3.0.7, but it is WFM with the latest trunk build on Windows XP.
These builds can be downloaded here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Version: unspecified → 1.9.0 Branch
Component: Style System (CSS) → Event Handling
QA Contact: style-system → events
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 445567
You need to log in before you can comment on or make changes to this bug.