Bug 483013 (cmd-q)

[Tracking] after a while, Mac FF gets flaky in many ways, and won't normal-quit

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: francis.uy, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
This has been happening to me for many months, and apparently to many other people as well.

After a variable amount (minutes, hours, days) of multi-tab browsing, Firefox fails in one or more of the following ways:

* new CSS stops loading (cached ones still work)
* new images stop loading (cached ones still work)
* JavaScript stops working
* new URLs stop working (cached pages still work via back/forward)
* Error Console, Preferences, etc stop working

The one symptom that remains true across all manifestations is that normal Quit (whether from the menu bar, dock, or cmd-Q) does not work, and Force Quit is required (sometimes twice). 

After reopening Firefox everything works again... until next time.

Since the bug never leaves a crash log behind, and there is no clear defining trigger, and the symptoms are so variable, I do not know if the other reported bugs here are duplicates or independent.
(Reporter)

Updated

10 years ago
Depends on: 383700, 402371, 424337, 430941
in addition to your initial blockers: bug 379795, bug 383700, bug 390264, bug 402296, bug 402371, bug 424271, bug 424337, bug 430941, bug 475161

there are
412382 Firefox hangs when quitting browser or applying update
410897 Firefox 3.0b2 crash on quit
449980 Firefox hangs when you try to quit the browser and have "Ask every time" set as default
474980 Hang on shutdown after being open for a while
479373 Hang on shutdown if there are outstanding SSL requests
474699 Sometimes the shutdown of Firefox takes ages while consuming 100% cpu load

But, if this didn't start for you until FF3, does it make sense to cite bugs here that began in FF2?
Keywords: meta
(Reporter)

Updated

10 years ago
Depends on: 474980
(Reporter)

Comment 2

9 years ago
I have not seen this happen any more in FF3.5.

Comment 3

9 years ago
No problems either here with FF 3.5.3 under Mac OS X 10.4.11.

Comment 4

9 years ago
The bug seemed to appear with FF 3.5.4, but only one URL was affected: one of the images from mailgraph.cgi (the other images were not affected). Firefox was trying to open the URL, but nothing happened (not even a timeout). Stop + Reload didn't have any effect, and "Live HTTP headers" didn't show any HTTP request (and the web server didn't receive any request). No problem with "wget". So, I eventually restarted Firefox and the problem disappeared.
Vincent, can you please file that as a new bug? This one is a tracking bug. Please CC me because today I already had another user who complained about that. Thanks.
I see a lot of bugs out there, both NEW and UNCONFIRMED, about not being able to quit gracefully on Mac. I'm seeing this behavior for the first time running FF 3.6 on Snow Leopard. I'm having difficulty reproducing, but it happens just about every time I leave FF running for a long time. Since I have to force quit, and it doesn't seem to be a crash, will a stack trace be generated (or be helpful)?

Updated

8 years ago
Depends on: 468736
See also Bug 1008609. I've been able to reproduce on very short sessions, and it seems to be related to clearing cached content. In the old days, it just rm'd the whole sub-directory structure -- a couple of years ago that was changed to a loop. It's now spending a lot of time in that loop, even though the panel says 0 bytes cached.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 800458
(Reporter)

Comment 9

3 years ago
Only one open item left (bug 430941).
Tracker is no longer needed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.