Major update page needed for Firefox 3.0 -> 3.5

RESOLVED FIXED

Status

defect
P2
normal
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: nthomas, Assigned: sgarrity)

Tracking

({fixed1.9.1})

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments)

For 2.0.0.x --> 3.0.y we set
  http://www.mozilla.com/en-US/firefox/3.0/details/index.html
as the location of the content for the major update offer. We need a similar page 3.0.x -> 3.5.y updates.

Obviously 3.5 is wee way out still but there are plans afoot to have major update available on the day of 3.5's release (to manual update requests only). And there's l10n lead-time, when those folks will also be busy with other site localisation. How soon can we finalise content for this new page ?
Blocks: 483053
(In reply to comment #1)
> For 2.0.0.x --> 3.0.y we set
>   http://www.mozilla.com/en-US/firefox/3.0/details/index.html
> as the location of the content for the major update offer. We need a similar
> page 3.0.x -> 3.5.y updates.
> 
> Obviously 3.5 is wee way out still but there are plans afoot to have major
> update available on the day of 3.5's release (to manual update requests only).
> And there's l10n lead-time, when those folks will also be busy with other site
> localisation. How soon can we finalise content for this new page ?

Would it be enough to just replace "3" with "3.5", and otherwise leave the rest of the text unchanged? 

I ask because http://www.mozilla.com/en-US/firefox/3.0/details/index.html already includes a link to http://www.mozilla.com/en-US/firefox/ which describes all the new features, etc - thats where all the localisation work and last minute "did this feature make it" changes would happen, aiui. Thats something we need for the FF3.5 release anyway, and is not related to doing major-update-on-release.
I don't think this content is appropriate for a new release:
  Firefox Security Alert!
  Immediate upgrade recommended.
  * Your current browser is no longer supported.
(In reply to comment #2)
> I don't think this content is appropriate for a new release:
>   Firefox Security Alert!
>   Immediate upgrade recommended.
>   * Your current browser is no longer supported.

Ah, yes. Agreed; I suspect that was used in the 3rd major update offer. Do we have the text used in the 1st major update offer dialogbox anywhere? Is it structured the same way: 
- some boilerplate intro text on the dialog box, and 
- a link to a more detailed page that would get last minute changes as new feature juggle around in the closing days of the release?
Jumping in on this - John/Nick - are you hoping to get a this in place to test major update mechanism prior to GA (i think i recall mention of this in weekly delivery meeting)? 

If its just for testing, we can use a placeholder, but if we need the real text/graphics, we'll need to create something new to be consistent with how we message 3.5 on the site. 

Assuming the spec for the billboard size remains the same (Sam?), i'll work with JSlater to add this to 3.5 launch delivery list. 

(Adding Slater and Sam to this bug)
(In reply to comment #4)
> Jumping in on this - John/Nick - are you hoping to get a this in place to test
> major update mechanism prior to GA (i think i recall mention of this in weekly
> delivery meeting)? 
> 
> If its just for testing, we can use a placeholder, but if we need the real
> text/graphics, we'll need to create something new to be consistent with how we
> message 3.5 on the site. 

My understanding (beltzner?) was that we would need the final page live on release of FF3.5, so that any user who did a manual "check for updates" would see this on FF3.5 release day. 

We're already doing testing of FF3.0.x->FF3.1b3 testing, so getting some sort of placeholder up would be great for that too.
ok, assuming the dimensions for major update billboard are the same as before, we can just update the logo treatment to be 3.5, refresh the text and then localize.

Is there a spec with the pixel dimensions for the billboard somewhere? I'll talk to Slater abt logo/copy refresh.
Probably not worth localizing a placeholder (if you meant that) but otherwise sounds like a good plan. 

Pascal, how long should be allowed for localization based on the prior experience?  Maybe we should aim to finalize the text by the RC1 code freeze (whenever that is).

Setting blocking3.5? on this so we don't lose track of it.
Flags: blocking-firefox3.5?
We need about 5 weeks to have all or almost all languages done for this project.
Yes, we do want to be able to have these billboards ready for when we launch to enable the "Check for updates..." upgrade path. So, blocking-indeed!
Flags: blocking-firefox3.5? → blocking-firefox3.5+
Priority: -- → P2
Per comment #6, what are the pixel dimensions of the html billboard that needs to be created? 

And Pascal, any insight you have into amount of copy that's most appropriate for localization. Assuming we have room for a logo, a few bullets of text but not much more.
For the text in the box, having about 30% free space horizontally and vertically for the English version should allow most translations to fit into the box.
Dave: I'm assigning this to you for now. If there's someone else who's working on this, feel free to hand it along, but seems like you're driving this right now.
Assignee: nobody → dbottoms
Re: comment #10, here's the super-rough wireframe we used to create the FF2->FF3 major update last summer. It has the various size breakdowns, which I'm assuming are still correct. If this is outdated, please let us know soon.
Posted file last major update
And here are the files for the FF2->FF3 major update from last summer. Unless there are major changes to the format, we'll probably follow this model again (with the necessary text & logo modifications).
Robert, could you comment on the size-of-content-pane questions above. Cheers!
There haven't been any changes to the size except for:

Bug 374820 reduced the available height on Mac OS X by 2px. This has landed on 3.0.x

Bug 475452 changed the remote css for #wrapper in update.css. This has landed in svn and is used by 3.0.x major update.

Other than that all should be the same. Beltzner asked me to take on changing the major update page in the wizard and I will hopefully be talking with him about these proposed changes tomorrow... I'll get back to you about the outcome.
(In reply to comment #16)
> Other than that all should be the same. Beltzner asked me to take on changing
> the major update page in the wizard and I will hopefully be talking with him
> about these proposed changes tomorrow... I'll get back to you about the
> outcome.
Hey all...just checking back in here. Any updates? On the marketing end of things, we're ready to get going on this whenever we have the final word on the size.

Thanks!
Hi all. Here's the proposed copy for this page...it was written to match the previous design, so let me know if the size of the window is changing beyond the 2px mentioned in comment #16.

Think Fast!
_Upgrade to Firefox 3.5._

* Twice as fast as Firefox 3.
* Private browsing, tear-off tabs and more.
* More ways to customize.

Next step after this is to pass the text along to Steven for development. Let me know if you see any blockers before I do that.
Had some offline conversations with Dave & Sam. Here's the revised version:

Think Fast!
_Upgrade to Firefox 3.5._

* Twice as fast as Firefox 3.
* Private browsing, tear-off tabs and more.
* The most advanced Firefox yet.

Will pass this along to Steven tomorrow...let me know if you have any thoughts before then.
It is not clear to me what 'Think Fast!' means in this context so I expect other localizers to wonder as well. I think it may  be understood as "we are giving you the possibility to upgrade now but make your decision fastly" but I guess the suggested meaning in English is 'this is really fast', right ?
(In reply to comment #20)
> It is not clear to me what 'Think Fast!' means in this context so I expect
> other localizers to wonder as well.
Yeah, that's a really good point. In this context it has a double meaning that I *think* will work well for English speakers, but I can see how it wouldn't translate. In that case, can we use that for en-XX locales and use something more straightforward for the localizations?

en-XX:

Think Fast!
_Upgrade to Firefox 3.5._

* Twice as fast as Firefox 3.
* Private browsing, tear-off tabs and more.
* The most advanced Firefox yet.

everyone else:

Time for an Upgrade!
_Get Firefox 3.5._

* Twice as fast as Firefox 3.
* Private browsing, tear-off tabs and more.
* The most advanced Firefox yet.
John, yes, that's better to avoid confusion
May I suggest we drop the trailing period on:
_Upgrade to Firefox 3.5._

It ends up looking a bit like it's supposed to be 3.5.something, but with the "something" missing.

I've added this en-XX text in trunk in r24360.
I've committed some layout/design changes in trunk in r24576 based on some feedback from dbottoms and jslater. Pascal, this might require a slightly smaller main headline font size for some locales.
Depends on: 489116
Any further progress on this?
Is it fair to say that en-US is done, and that 18 translations have been submitted on bug 488640 ?
Nick, Al, follow the web dashboard to know the progress on web localization:

http://l10n.mozilla.org/webdashboard/?project=5&task=Translate+Major+Update+box+for+Firefox
32 locales done, they are on trunk for now but I will push them live soon
When you push them live, let me know and I and Juan can look at them sooner. Juan pointed out that Nick had given us a method to bring up the Major Update dialog without needing snippets to be live. So we can test these in batches as they are live on the web site.
I'm going to setup a 3.0.10 to 3.5b4 path pretty soon (in bug 459878), and I think we fallback to en-US in the absence of a localized version, so we'll pick the localized offers as they're pushed.
The 3.0.10 to 3.5b4 update path is now ready for testing (on the betatest channel). Not sure when QA will have an opportunity to look at it, but could we push en-US and the completed locales sometime soon ? If we're ready that is.
The placeholder page, which we are using for the 3010->3.5b4 testrun on betatest, isn't ready: http://www.mozilla.com/en-US/firefox/3.5/details/index.html
Who is going to own this bug now ? Is there anything preventing pushing the en-US page live and resolving this bug ?
(In reply to comment #33)
> Who is going to own this bug now ? Is there anything preventing pushing the
> en-US page live and resolving this bug ?

If this is just a matter of pushing the files to stage, for production, then I can do that. However, this bug apparently depends on Bug 489116, which hasn't been resolved yet.
Duplicate of this bug: 489116
John can confirm, but I don't think it was the intention to have no scrolling at all even when the incompatible extensions pane was open.
Personally, I'd expect scrolling when the incompatible extensions are found but not in the standard case where they weren't.
Well, the 3.0 layout (http://www.mozilla.com/en-US/firefox/3.0/details/) fit in a shorter space, but it only had two lines of text, rather than three.
(In reply to comment #37)
> Personally, I'd expect scrolling when the incompatible extensions are found but
> not in the standard case where they weren't.
Yes, that was the plan - no scrolling in the standard case, scrolling when the extensions message is shown.  

This promo was created based on the dimensions of the 3.0 major update and I don't recall hearing any issues about scrolling then. Has something changed?

Having said all that, the most important thing by far is that the "Upgrade to Firefox 3.5" is visible for everyone at all times. As long as that's the case, the scrolling vs no scrolling thing is very much a secondary issue.
The logo is larger in this version, I believe. As QA, I'd like to not see scrollbars out of the box, so to speak.
(In reply to comment #40)
> The logo is larger in this version, I believe. As QA, I'd like to not see
> scrollbars out of the box, so to speak.
Steven is going to make some tweaks...stay tuned for some refinements coming soon.
Here's a preview of a simpler (and a bit less awesome) layout that better accommodates the various window sizes.
A+

It looks good to me.
Looks good to me, too - thanks Steven!!
Committed these layout changes in r25909. Let me know if there are any l10n issues
Do we mark this as FIXED or only when it gets pushed live? Also: any danger of pushing it live now?

l10n'ing this is bug 488640
Assignee: dbottoms → steven
Poke/prod: can we close this out?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.