Directories displayed twice in file:/// URLs

RESOLVED FIXED

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: Jeffrey Baker, Assigned: Robert John Churchill)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Linux 2000-08-09-10.  To reproduce

1) go to file:///
2) all directories shown twice

Screenshot attached.
(Reporter)

Comment 1

18 years ago
Created attachment 12652 [details]
Screenshot from Linux

Comment 2

18 years ago
Yup, that's a real defect alright, but not a toolkit problem.  ->waterson
Assignee: trudelle → waterson

Comment 3

18 years ago
To rjc. Probably related to the work-around for bug 47927 that I checked in.
Assignee: waterson → rjc
(Assignee)

Comment 4

18 years ago
A little investigation on Gagan's fast-as-hell Linux screamer revealed that this:



  o only happens the very first time (so need to quit/re-run after each test)

  o only directories appear to be duplicated (with the first entry inside of it)



It looks like using nsIFile::GetDirectoryEntries() is the culprit... over to 

dougt.

Assignee: rjc → dougt
(Assignee)

Comment 5

18 years ago
*** Bug 48485 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
happens on NT too - OS --> ALL
OS: Linux → All

Comment 7

18 years ago
I don't think that this is nsLocalFile.  Checkout the testcase:


nsIFileEnumerator under xpcom/tests/



I also put a printf in RDF filesystem datasource and here is the output (for my
/):

 ---> lost+found
 ---> home
 ---> proc
 ---> var
 ---> tmp
 ---> dev
 ---> usr
 ---> etc
 ---> bin
 ---> boot
 ---> lib
 ---> mnt
 ---> opt
 ---> root
 ---> sbin
 ---> dos
 ---> dos2
 ---> lost+found
 ---> mdstat
 ---> lib
 ---> install.log
 ---> log
 ---> doc
 ---> csh.cshrc
 ---> mktemp
 ---> kernel.h
 ---> modules
 ---> cdrom
 ---> ldconfig
 ---> suhdlog.dat
 ---> recycled
 ---> lost+found
 ---> mdstat
 ---> lib
 ---> install.log
 ---> log
 ---> doc
 ---> csh.cshrc
 ---> mktemp
 ---> kernel.h
 ---> modules
 ---> cdrom
 ---> ldconfig
 ---> suhdlog.dat
 ---> recycled


but in mozilla, I do see extra entries....

more investigation is needed.

Comment 8

18 years ago
when I said that i saw extra entries, I mean in the filetree displayed in the
mozilla content area.


back to rjc.  
Assignee: dougt → rjc
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

18 years ago
I checked in a quick fix for this bad interaction between the rdf:httpindex and 
rdf:files datasources.
You need to log in before you can comment on or make changes to this bug.