Closed Bug 483251 Opened 16 years ago Closed 15 years ago

Show keywords for search in adressbar does not work for capital %S

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 454208

People

(Reporter: bxt, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

If you have a bookmarked search that opens a URL and therefor usees the capital %S (no encoding), than typing it's keyword in the addressbar will show the bookmark but not as search and the %S is not replaced with your search string. If you just hit enter eveything works fine, but if you select the bookmark from the suggestions it doesn't replace the %S in the new location too. 

Reproducible: Always

Steps to Reproduce:
1. Add a new bookmark. URL: "http://example.com/%S", Keyword "e"
2. Type in the adress bar "e some/directory"
3. Notice that http://example.com/%S is displayd as a search result in your bookmarks (though it doesn't even contain "some/directory")
4. Hit Enter and get to http://example.com/some/directory or select the bookmark in the search results (the suggestions) and you get to http://example.com/%S
Actual Results:  
I can't know it's a search keyword and it takes me to the worng url. 

Expected Results:  
Schould show me the same thing as if i had bookmarked it with a %s (So replacing the %S in the url and add it to the title. Even show the lens on the right)
Whiteboard: wontfix?
Seems to work for me on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090313 Minefield/3.2a1pre

I tried this twice, once using your exact example, and again  for cnn.com search.

Also tested on 3.1b3 released build on Linux and Windows: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3.

Make sure you try again in Firefox's Safe Mode.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Anyway it still doesn't work for me. It even seems like the feature has been dropped? I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090610 Shiretoko/3.5pre
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → DUPLICATE
Whiteboard: wontfix?
You need to log in before you can comment on or make changes to this bug.