suppress the soft keyboard on winCE when a real keyboard is out

VERIFIED DUPLICATE of bug 341772

Status

Fennec Graveyard
General
VERIFIED DUPLICATE of bug 341772
9 years ago
9 years ago

People

(Reporter: madhava, Assigned: dougt)

Tracking

Trunk
ARM
Windows CE

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 367257 [details]
the two parts I'm talking about

At least on the HTC Touch Pro, when I have the physical keyboard deployed, we should repress the soft keyboard and the little keyboard-related box at the bottom of the screen (a and b, respectively, in the attached diagram).
(Assignee)

Updated

9 years ago
Assignee: nobody → doug.turner
(Assignee)

Updated

9 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0-wm+
(Assignee)

Comment 1

9 years ago
I have tried:

1) HKCU\Software\Microsoft\Shell\HasKeyboard. This value stays the same no matter if the keyboard slide to the open position or not.

2) GetKeyboardStatus(). Same as above

3) Smart Auto-Deploy event. I tried listening for the “_KeyPress” event. That seems to work fine (I know that a key was pressed on the hardware keyboard), but it really doesn’t tell you if the keyboard has been slide closed again.

blogged about needing more information, but so far the internetz don't know.
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 341772
verified with 20090828 1.9.2 nightly winmo build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.