TM: JIT content breaks Bluehost.com File Manager display of files in right-hand pane

RESOLVED FIXED

Status

()

Core
JavaScript Engine
P2
major
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: IU, Unassigned)

Tracking

({fixed1.9.1, regression})

Trunk
fixed1.9.1, regression
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Can reproduce without account. See Comment #7, URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090313 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090313 Firefox/3.0

Since the March 10 Nightly build, the bluehost.com File Manager, which is used for managing user web content on the hosting company's server, is now broken with JIT content enabled.  Specifically, when clicking a folder on the left-hand pane, the folder content is no longer being displayed in the right-hand pane (only a very limited number of folders are displayed).  Disabling JIT content resolves the issue.

The following also appears in Error Console:

Error: a is undefined
Source file: https://box556.bluehost.com:2083/cPanel_magic_revision_1232681456/frontend/bluehost/js/filemanager_optimized.js
Line: 1

Verifying this requires a bluehost.com account.  I will be attaching the filemanager_optimized.js file referenced in the Error Console message.


Regression window:

Works: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090309 Minefield/3.2a1pre ID:20090309032542
http://hg.mozilla.org/mozilla-central/rev/50169589cc51

Fails: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090310 Minefield/3.2a1pre ID:20090310044308
http://hg.mozilla.org/mozilla-central/rev/73efb0ef0d79


Reproducible: Always

Steps to Reproduce:
1. [bluehost.com account required]
2. Login to your bluehost.com account and, under the Files group, choose "File Manager"
3. Browse your folder tree (on the left) and notice that, for the most part, nothing is appearing in the right-hand pane.  Also take note of the error in Error Console.
4. Now disable javascript.options.jit.content
5. Once again, browse your folder tree.  Notice that everything now works as it should.
(Reporter)

Updated

10 years ago
Component: General → JavaScript Engine
Keywords: regression
OS: Windows XP → All
Product: Firefox → Core
Hardware: x86 → All
Version: unspecified → Trunk

Updated

10 years ago
Component: General
Keywords: regression
OS: All → Windows XP
Product: Firefox
Hardware: All → x86
Version: Trunk → unspecified
(Reporter)

Comment 1

10 years ago
Created attachment 367266 [details]
JavaScript file JIT content is failing on
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3.1?
(Reporter)

Updated

10 years ago
Keywords: regression
(Reporter)

Updated

10 years ago
Component: General → JavaScript Engine
Flags: blocking-firefox3.1?
OS: Windows XP → All
Product: Firefox → Core
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Flags: blocking1.9.1?
(Reporter)

Comment 2

10 years ago
This also fails on latest TraceMonkey nightly.

Comment 3

10 years ago
(In reply to comment #1)
> Created an attachment (id=367266) [details]
> JavaScript file JIT content is failing on

Is there any way you could save the file manager page locally, and upload it here?
(Reporter)

Comment 4

10 years ago
I'll try, but it didn't seem to work well for me.  I'll also see if capturing with ScrapBook extension will work any better.
(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
> Is there any way you could save the file manager page locally, and upload it
> here?

I'm not sure this is going to work.  When I launch the page from a local copy I get the following:

Error: uncaught exception: [Exception... "Access to restricted URI denied"  code: "1012" nsresult: "0x805303f4 (NS_ERROR_DOM_BAD_URI)"  location: "file:///D:/index_files/utilities_container.js Line: 15"]

...and it shows "Loading data..." in the right-hand pane.

Are you sure that's going to be useful to you?
(Reporter)

Comment 6

10 years ago
Created attachment 367274 [details]
bluehost.com File Manager page (saved after JIT content disabled)

Here you go.
Assignee: nobody → general
QA Contact: general → general
(Reporter)

Comment 7

10 years ago
Okay everyone should be able to verify this bug now.  Bluehost actually has a Live Demo site.  Here are the steps to perform:

1. Make sure JIT content is enabled
2. Go to http://www.bluehost.com/tell_me_more.html
3. Click "Demo Login..." on the right-hand side
4. Wait for the Bluehost cPanel to load
5. Click "No I'm fine thanks," on the "Do you need help getting started?"
6. Scroll to the "Files" group and click "File Managager"
7. Wait for the "File Manager" page to load
8. On the left-hand side you have the directory/folder tree.  On the right-hand side is where its contents are supposed to be listed.
9. Notice, for instance, that when you click the "public_html" root on the left, nothing show up on the right.
10. Now disable JIT content and retry Step  9.  Notice that the right-hand side is not populated.
Whiteboard: Can reproduce withou account. See Comment #7
(Reporter)

Updated

10 years ago
Whiteboard: Can reproduce withou account. See Comment #7 → Can reproduce without account. See Comment #7
(Reporter)

Updated

10 years ago
Blocks: 451602

Updated

10 years ago
Flags: blocking1.9.1? → blocking1.9.1+
(Reporter)

Comment 8

10 years ago
(In reply to comment #7)
> 10. Now disable JIT content and retry Step  9.  Notice that the right-hand side
> is not populated.

Sorry.  That should read ..."Notice that the right-hand side is [NOW] populated."

Updated

9 years ago
Priority: -- → P2
(Reporter)

Comment 10

9 years ago
This has been fixed for about a week now, since a few TM check-ins ago.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 11

9 years ago
Thanks for retesting IU.

Updated

9 years ago
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.