If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tbird shows count of all messages in all folders, as opposed to number of new messages

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Chris Malton, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

I upgraded to TBird 3.0b2 from 2.0.0.19, and since then when new mail has arrived, I have got the popup showing the number of "new" messages.  As it happens, this actually (I believe) shows the total count of all messages across all folders.

I am using two IMAP(SSL) accounts and an RSS account, set to check for new mail on my dovecot IMAP(SSL) every minute.

Reproducible: Always

Steps to Reproduce:
1. Upgrade from TBird 2.0.0.19
2. Send a test message to yourself
3. Look at the popup to alert you of new messages
Actual Results:  
See http://www.cmalton.me.uk/subs/hosting/chrism/gallery/TBMailBug.PNG
The popup displays the total number of messages in all mailboxes registered with TBird - I believe.

Expected Results:  
The popup should only display the number of *unread* messages in all mailboxes on the specified account.
Whiteboard: DUPME
(Reporter)

Comment 1

9 years ago
Looks like this is fixed in latest nightly - "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090313 Shredder/3.0b3pre" dated Mar 13th 4:32 AM

Comment 2

9 years ago
->WFM then
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

9 years ago
Update

Latest nightly is exhibiting strange behaviour with unread message counts which tend to show numbers which bear no resemblance to the actual number of unread messages, nor the total number of messages.  In actual fact, it seems to be some random number that got plucked out of some memory location.

Will grab a screenshot when it next happens and post here.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

9 years ago
sounds like bug 482754 STATUS command which thinks is a trunk regression of bug 428266 which checked in 2009-03-09.  bug 468499 may be another case. 

I see incorrect message count only when "check this folder for new messages" property is set for a folder that is a target of filtered mail. Inbox count is fine.

Somewhere in the last month the count for this folder stopped updating when new mail arrived, and only updates when I click the folder.  So I set "check this folder for new messages"  hoping it would fix this problem, which it didn't.
Component: General → Folder and Message Lists
Keywords: regression
QA Contact: general → folders-message-lists
Version: unspecified → Trunk

Comment 5

9 years ago
(In reply to comment #4)
> sounds like bug 482754 STATUS command which thinks is a trunk regression of bug
> 428266 which checked in 2009-03-09.  bug 468499 may be another case. 
> 
> I see incorrect message count only when "check this folder for new messages"
> property is set for a folder that is a target of filtered mail. Inbox count is
> fine.
> 
> Somewhere in the last month the count for this folder stopped updating when new
> mail arrived, and only updates when I click the folder.  So I set "check this
> folder for new messages"  hoping it would fix this problem, which it didn't.

msg counts are now correct for me as of 2009-03-25 nightly with "check this folder for new messages". I don't have a small regression range but it is between 2009-03-13 and today 2009-03-25 because my incorrect

Comment 6

9 years ago
bah, scuttle comment 5. it's back

Comment 7

9 years ago
Chris, can you try nightly build?
Severity: major → normal
(Reporter)

Comment 8

9 years ago
Appears to have got fixed in trunk while I wasn't looking.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED

Comment 9

9 years ago
->WFM (FIXED is used only when known code changes resolved the issue)
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.