Selection of anonymous contained in div isn't visible

RESOLVED WORKSFORME

Status

()

Core
Selection
P2
major
RESOLVED WORKSFORME
18 years ago
12 years ago

People

(Reporter: Blake Ross, Assigned: David Hyatt)

Tracking

({helpwanted})

Trunk
Future
x86
Windows 98
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p:2])

(Reporter)

Description

18 years ago
Build ID: 2000080809

Steps to Reproduce:
(1) Load XBL Demo #2 (Rollover Madness) from the Debug menu.
(2) Choose Edit | Select All and note that you can select the text of the div 
if the mouse isn't over it (and it's not in the rollover state)
(3) Now put the mouse over the div so its styling/borders change and try to 
select the text. 

Result: the text is unselectable.  Note also that it simply can't contain a 
selection at all -- if you right-click while the mouse is over the div and you 
press L (the access key for Select All in the context menu, the demo 
explanatory text will get selected, but not the text contained in the div. But 
then if you mouseout of the div, the text is selected.
(Reporter)

Comment 1

18 years ago
OK, it's not even that the text isn't being selected (it is, since you can copy 
it), just that the selection isn't showing up.  cc'ing simon
Summary: Can't select text contained in div → Selection of text contained in div isn't visible
(Assignee)

Comment 2

18 years ago
I have an even better case.  I'll probably make it XBL Test #6... it looks like 
anonymous content doesn't get selected... possible an assumption somewhere in 
the selection code where it walks the content model instead of the frame tree.
(Reporter)

Comment 3

18 years ago
*SPAM*: Changing the QA contact of all open/resolved Selection bugs from 
elig@netscape.com to BlakeR1234@aol.com.  After the many great years of service 
Eli has given to Mozilla, it's time for him to move on; he has accepted a 
position at Eazel.  We'll be sad to see him go, and I'll do my best to fill his 
spot...
QA Contact: elig → BlakeR1234
(Reporter)

Updated

18 years ago
Summary: Selection of text contained in div isn't visible → Selection of anonymous contained in div isn't visible

Comment 4

18 years ago
setting to m19, p2 and adding correctness keyword
Severity: normal → major
Keywords: correctness
Priority: P3 → P2
Whiteboard: [p:2]
Target Milestone: --- → M19
(Assignee)

Comment 5

18 years ago
This should not be fixed for 6.0... it's not that big a deal.

Comment 6

18 years ago
moving to future
Keywords: helpwanted
Target Milestone: M19 → Future

Comment 7

17 years ago
the problem is that the frames are being redrawn and selection is not being 
"refreshed".  when we get a new focus event we refresh the selection to "reset" 
the frames that have the selection bit on.  this should be easy to fix. i am 
assigning to hyatt. he may not fix it but he will know where this 
rebinding/change of frame hierarchy is taking place.

feel free to contact me to sit down and help
Assignee: mjudge → hyatt
(Reporter)

Comment 8

17 years ago
changing selection qa to tpreston.
QA Contact: blaker → tpreston

Comment 9

17 years ago
removing myself from the cc list

Comment 10

15 years ago
WFM (build ID: 2003042608) on Win98 following the "steps to reproduce" from the
original bug report. Maybe this got fixed as a side effect of another bug fix. :)
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040207
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.