[INLINE-V][quirks]Image overlaps text due to line-height: 0

VERIFIED WONTFIX

Status

()

Core
Layout
P3
normal
VERIFIED WONTFIX
18 years ago
17 years ago

People

(Reporter: Sander van Rijnswou, Assigned: dbaron)

Tracking

({compat})

Trunk
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Go to the mentioned url. You'll see a the gif running through the date.
Explorer and navigator do not do this.

Comment 1

18 years ago
Confirmed: the "sep_line.gif" IMG is displayed over the bottom half of the
text "August 11, 2000" at the top of the frame; everything else below is moved
up the same amount. Tested with the 2000-08-11-08-M18 nightly binary on WinNT.

Resummarizing from "Gif is displayed throug text" to "Gif appears over text in 
DIV with only margin-left property"

The relevant part of the html code is:
  <HTML>
  <HEAD>
  <LINK REL=STYLESHEET TYPE="text/css" HREF="/style.css">
  </HEAD>
  <body leftmargin=0 topmargin=0 vlink="#575759" text="#000000" 
  bgcolor="#CECE9C" alink="#0000ff" link="#00008b">
  <DIV class=welcome>
  <NOBR><FONT class=date>August 11, 2000</FONT></NOBR>
  </DIV>
  <IMG SRC="/images/menu/sep_line.gif" HEIGHT=6 WIDTH=130>
  ...
  </body _parsed>
  </HTML>

And the relevant fragment from "/style.css" is
  DIV.welcome { margin-left: 10px; }

David: this looks like something similar to one of the bugs marked "[MARGIN-C]"
but I'm not going to try to decide if I've found a DUP. Please resolve this
as a DUP if it is...

Sander, - could you please read the Bug Writing Guidelines at 
<http://www.mozilla.org/quality/bug-writing-guidelines.html> to see the
kinds of information we need in a bug report. In the future, please report 
the BuildID (in the title bar) or Milestone name of the Mozilla code you
are using. 

You may want to consider using the Bugzilla Helper to report future bugs. 
The Helper can be found at <http://www.mozilla.org/quality/help/bug-form.html>  
Thanks for your help in testing Mozilla.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css1
Summary: Gif is displayed throug text → Gif appears over text in DIV with only margin-left property
The MARGIN-C bugs are margin collapsing, which is for vertical margins only. 
I'll look at this more later.
This looks like a problem with the quirks-mode inline box model.  Assigning to
myself for further investigation, although I'm not sure I'll have time.
Assignee: clayton → dbaron
Summary: Gif appears over text in DIV with only margin-left property → [INLINE-V][quirks]Image overlaps text due to line-height: 0
Target Milestone: --- → M19
The quirks mode inline box model is working as I expected it to.  So I don't
understand (after 2 minutes of poking around) what Nav4 and IE are doing.  Any
thoughts?

Comment 6

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca
(We display the testcase per the specs, so changing css1 to compat.)

dbaron: *shrug* Looks like IE is even more quirky than we imagined. Do we really
care that much? There's a simple work around -- don't say line-height:0. I don't
see any advantage to saying that anyway. WONTFIX?
Keywords: css1 → compat
QA Contact: lorca → py8ieh=bugzilla
I don't think it's per specs, but it's per our understanding of quirks mode. 
Since we're not going to have time to look at this before we ship, and after we
ship we'll have already set a precedent, marking WONTFIX.  Considering this is
the only known bug report on this issue, I don't think it's going to be common.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
ok
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.