Closed Bug 483482 Opened 13 years ago Closed 13 years ago

TM: Crash with JIT chrome enabled [@ js_TraceObject ]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 483485

People

(Reporter: fehe, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

76.46 KB, application/zip
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090314 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090314 Minefield/3.2a1pre

If JIT chrome is enabled, visiting the linked URL (or opening the attached test case) results in a crash.

http://crash-stats.mozilla.com/report/index/fbba899c-729e-4998-9f0c-60f762090314

This is a recent regression, but I don't have time to search now.


Reproducible: Always

Steps to Reproduce:
1. Download and extract the attached file
2. Double-click xul.html
3. Minefield crashes
Component: General → JavaScript Engine
Product: Firefox → Core
Version: unspecified → Trunk
Attached file test case
Depends on: 483485
bp-fbba899c-729e-4998-9f0c-60f762090314
0  	js3250.dll  	js_TraceObject  	 js/src/jsobj.cpp:5754
1 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
2 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
3 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
4 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
5 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
6 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
7 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
8 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
9 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
10 	js3250.dll 	JS_CallTracer 	js/src/jsgc.cpp:2736
11 	xul.dll 	XPC_WN_Shared_Trace 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:707
12 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5732
13 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
14 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
15 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
16 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
17 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
18 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
19 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
20 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5754
21 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
22 	js3250.dll 	JS_CallTracer 	js/src/jsgc.cpp:2736
23 	xul.dll 	XPC_WN_Shared_Trace 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:707
24 	js3250.dll 	js_TraceObject 	js/src/jsobj.cpp:5732
25 	js3250.dll 	JS_TraceChildren 	js/src/jsgc.cpp:2460
26 	js3250.dll 	JS_CallTracer 	js/src/jsgc.cpp:2736
27 	js3250.dll 	fun_trace
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483485
Crash Signature: [@ js_TraceObject ]
You need to log in before you can comment on or make changes to this bug.