Firefox is continually crasing on all different websites whjavascript:function%20loadScript(scriptURL)%20{%20var%20scriptElem%20=%20document.createElement('SCRIPT');%20scriptElem.setAttribute('language',%20'JavaScript'enever I have more than one tab open.

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: alishayouch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 FBSMTWB
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 FBSMTWB

Browser is crashing by locking up, unable to shut it down normally, even with Ctrl+alt+delete.  I must use the off button most of the time.  If I do manage to shut it down, when I try to restart, I am told that Firefox is already running, and when I look in the Task Manager, it IS still showing up there.  (I am able to shut it down through Task Manager at that point, but if I resume my session, it crashes again, even if I eliminate all but one tab.

Reproducible: Sometimes

Steps to Reproduce:
1. Open more than one tab
2.Alternate back and forth
3.Open a pop-up window, and parent window disappears or locks up.
Actual Results:  
The parent window locked up, disappeared, showed itself when I used Alt+ tab to move between windows, but it would not recover, and I had to reboot with the off button again.

Expected Results:  
I had to reboot, and when I restarted Firefox and elected to resume my session, the same thing happened.  Only by starting a new session can I avoid a recurrence.

It should have remained open and responded by shutting down correctly when I hit the x in the top right corner.  It also should have allowed me to Alt+tab between windows without crashing.
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3.2?
Flags: blocking-firefox3.1?
It's a system issue if Firefox hangs and can not be closed by the taskmanager /process tab). This can be only caused by drivers running in the kernel mode of the OS like a Firewall driver, an Anti-virus driver, a graphic card driver....

It's never the fault of a userspace application that doesn't install drivers running in the kernel mode if the process can not be killed. 
One known example that is doing this is the Zonealarm Firewall.
Hardware: PowerPC → x86
As a policy, we don't block on unconfirmed bugs. Please work with Matthias to see if you can get this confirmed.

For what it's worth, giving us a URL of the pop up window that's causing this might help us diagnose the problem. Though, as Matthias says, this doesn't sound like the problem is in Firefox, even though we may be exposing it.
Flags: blocking-firefox3.2?
Flags: blocking-firefox3.1?
-> invalid (can not be our fault)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.