Closed Bug 483504 Opened 12 years ago Closed 11 years ago

Minimize button frequently grays out

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 526282

People

(Reporter: jbhelmly, Unassigned)

Details

(Whiteboard: [3.6.x])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7

I frequently have my minimize button grayed out which prevents me from minimizing the impacted Firefox window.  I am still trying to determine if there are any common sites, types of sites, or situations that cause it, but it happens on a regular basis.  Yesterday I had two Firefox windows open (non-full screen mode).  I noticed one had the problem earlier in the day and the other did not.  By the end of the day, both had the problem.  I had accessed pages on Strayer.edu, Cisco.com, Fox.com, google.com, and others.  I have the "Always show Tab bar" option on as well as open new pages in a tab. 

Reproducible: Sometimes

Steps to Reproduce:
1. General browsing with tabs
2. Keep an eye on the minimize button
3. Eventually the Minimize button will be grayed out
4. Try toggling maximize
5. Look for other hidden Firefox windows
6. Still looking for more exact steps
Actual Results:  
Eventually it gets to where I cannot minimize the Firefox window.  Even toggling the maximize window setting (button) does not restores the minimize window function. 

Expected Results:  
As long as the window is not maximized, I should have a minimize button.
Have you tried safe mode?
I did a capture of a Firefox window with the minimize button inactive.  I don't know if this is a Firefox or Mac issue, but I don't remember seeing the same issue with any other applications.
(In reply to comment #1)
> Have you tried safe mode?

What do you mean by safe mode?  If you're referring to MS Windows safe mode, this is on a Mac running Mac OS X 10.5.6.
I've had this same issue with camino for a while. I can't say if its OS X related but it happens to camino more frequenty since the last security update. I'm running  camino Version 1.6.8pre (1.8.1.22pre 2009050900) and 10.4.11 with all available updates on a 15" 1.667 GHz powerbook g4.  I don't play or have any games installed and haven't used any full screen apps since the last reboot.  Double clicking the title bar and CMD-M are disabled in camino too.  I checked the console.log and system.log but I don't see anything unusual going on. I seen this issue for probably a year.  It goes away by quitting camino and restart it.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100105 Firefox/3.6
=> actually 10.6.2

The problem seems to be connected with the full view mode (shift+cmd+F):

After applying the full view mode and getting back to the normal window the minimize button is greyed out while cmd+M is still working.
Flags: blocking-firefox3.6?
Confirmed based on steps in comment 5:

 - enter full screen mode
 - return to normal mode
 - look at minimize "gem"

expected: it's there, as usual
actual: it's disabled, doesn't respond to clicks

Not a release blocker, but definitely want to clean it up.

--> Core::Widget and cc'ing the OSX folks.
Status: UNCONFIRMED → NEW
Component: General → Widget: Cocoa
Ever confirmed: true
Flags: blocking-firefox3.6?
Product: Firefox → Core
QA Contact: general → cocoa
Whiteboard: [3.6.x]
I just need to land bug 526282.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526282
You need to log in before you can comment on or make changes to this bug.