Last Comment Bug 48358 - hotmail home page is blank
: hotmail home page is blank
Status: VERIFIED FIXED
[nsbeta3+]
: top100
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: P3 major (vote)
: ---
Assigned To: ruslan
: Tom Everingham
Mentors:
http://www.hotmail.com/
: 48625 50253 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 03:53 PDT by Rod de Lima-Lopes
Modified: 2000-08-24 19:44 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
The fix (427 bytes, patch)
2000-08-17 14:06 PDT, ruslan
no flags Details | Diff | Splinter Review

Description Rod de Lima-Lopes 2000-08-10 03:53:16 PDT
mozilla does not load webmail pages, sucha as www.hotmail.com all we get is a
blank page
Comment 1 Jeffrey Baker 2000-08-10 08:57:09 PDT
Hrmm.  This seems to be a bad interaction between Mozilla and Microsoft IIS 5.0,
which is not strictly following RFC 2616.  I believe the problem is that Mozilla
is sending a Connection: keep-alive, while IIS is responding with a 302, and
closing the connection but *not* sending Connection: close.  The RFC states:

"If the server chooes to close the connection immediately after sending the
response, it SHOULD send a Connection header including the connection-token close"

Since the specification uses SHOULD instead of MUST, Mozilla should be able to
handle this situation.  4.x handles this fine.

Reassigning to networking.
Comment 2 Blake Ross 2000-08-10 09:06:14 PDT
'correctness' doesn't make sense in this case

nominating for beta3.
Comment 3 LinuxLover 2000-08-10 13:56:55 PDT
present in M17 and M18 nightly (10 Aug 2000)
Comment 4 Gagan 2000-08-10 14:06:12 PDT
->ruslan
Comment 5 ruslan 2000-08-10 14:52:02 PDT
Hmm. Looks like hotnail just drops the connection after the first request line 
not even sending a newline after headers. This is bizare ...
Comment 6 ruslan 2000-08-10 14:53:30 PDT
cc: gagan
Comment 7 Jeffrey Baker 2000-08-15 08:35:08 PDT
*** Bug 48625 has been marked as a duplicate of this bug. ***
Comment 8 Jeffrey Baker 2000-08-15 08:37:13 PDT
Wow IIS is a real piece of junk.  It sends the response and drops the connection
after the very first \n, just like ruslan said.  That is totally against RFC
2616, if my reading is correct.  It seems like the proper handling of this case
is to display an error page.
Comment 9 ruslan 2000-08-15 09:52:22 PDT
What I'm thinking however is putting a kludge which will fire OnHeadersAvailable 
right inside of OnStop if Location header is detected - a bit tricky but it can 
be done. Putting up an error message is tempting, but I don't know if PDT will 
agree with that. BTW - removing regression keyword - it's not out regression, 
but MS's.
Comment 10 Gagan 2000-08-16 01:15:12 PDT
The reason this worked in 4.x is that we initiated the new redirected request
right after detecting the Location header. (And hence never really waited for
anything else) This is obviously the wrong thing to do in the new world order. I
am proposing a quirk mode option to enable sending OnHeadersAvailable right
after Location header to mimic this behaviour. 
Comment 11 Jeffrey Baker 2000-08-16 10:37:49 PDT
Just to be clear, there are three abnormal behaviors demonstrated by hotmail in
this example:

1) The server is responding after the first newline.  This is against the RFC
2) The server is sending only one CRLF after the response.  Also against the RFC
3) The server is not sending Connection: close, which is recommended by the RFC
Comment 12 ruslan 2000-08-17 14:06:49 PDT
Created attachment 13066 [details] [diff] [review]
The fix
Comment 13 ruslan 2000-08-17 14:15:26 PDT
Proposed fix attached. Awaiting review - Gagan?
Comment 14 ruslan 2000-08-18 12:39:47 PDT
Fixed
Comment 15 Jeffrey Baker 2000-08-20 15:25:48 PDT
Hotmail homepage now loads on Linux 2000-08-19-08.  All hail IIS 5.0.  sigh.
Comment 16 Asa Dotzler [:asa] 2000-08-24 18:35:09 PDT
*** Bug 50253 has been marked as a duplicate of this bug. ***
Comment 17 Tom Everingham 2000-08-24 19:44:39 PDT
verified:
WinNT 2000082308
Linux 2000082408
Mac8.6 2000082308

Note You need to log in before you can comment on or make changes to this bug.