F6-Key does not focus URL address input when in fullscreen mode

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: geroxp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7

If I hit the F6 key in non fullscreen mode I can instantly type a new address into the address input field. This does not work when in fullscreen mode (F11). The address input is shown but it has no focus. This functionality is important on computers with small screen. When opening a new tab in fullscreen mode one might want to get to the address input field to type in the new location.




Reproducible: Always

Steps to Reproduce:
1. Open Firefox, press F11 for fullscreen
2. Press CTRL-T for a new tab
3. Press F6 for location input focus

Actual Results:  
Address input field shows up


Expected Results:  
Show address input field and focus it

Usability and maybe accessibility issue.
(Reporter)

Comment 1

10 years ago
I cannot reproduce in trunk. This bug only applies to FF 3.0.7 (and maybe prior version). Thus I am marking it as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.