quick search filters incorrectly in beta2 (first session only)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: jberkus, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.19) Gecko/20081212 Camino/1.6.6 (like Firefox/2.0.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

In 3.0b2, Quick Search filters a random set of mail which has nothing to do with the search terms.

Reproducible: Always

Steps to Reproduce:
1. Open a mailbox with lots of mail.
2. Search on a sender name, like "Virgil" or "Baron"
3. Mail gets filtered to a subset of mail (around 50%), but which mail displays has nothing to do with the search term.
Actual Results:  
Mail gets filtered to a subset of mail (around 50%), but which mail displays has nothing to do with the search term.

Expected Results:  
Mail should get filtered to e-mail whose headers or senders contain the search term.

Server is IMAP.
See it after the first usage too?
(Reporter)

Comment 2

10 years ago
Magnus,

Shutting down thunderbird, restarting it, shutting it down again, and restarting it again made the issue go away.  I'll comment if it returns again with use.
I saw it too, the one first time. (With b1, iirc.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Summary: quick search filters incorrectly in beta2 → quick search filters incorrectly in beta2 (first session only)
did you have folders open in tabs?
I also saw this also recently. Never seen in 2.0 iirc
>MWFE for now
Component: General → Mail Window Front End
Keywords: regression
QA Contact: general → front-end
Version: unspecified → Trunk
dupe of bug 472156?
Whiteboard: dupeme
I haven't seen this in ages. => WFM
please reopen if you disagree
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.