Steals UI focus twice as page loads

VERIFIED INVALID

Status

Fennec Graveyard
General
VERIFIED INVALID
9 years ago
8 years ago

People

(Reporter: Matthew Craig, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3) Gecko/20090313 Shiretoko/3.1b3
Build Identifier: 

Rendering a page can take a bit of time, especially on long web pages.  It is common to switch tasks while this is taking place.  Unfortunately, the browser will "steal the UI focus" twice while the page loads, even before it has completed rendering.  The user must minimize the browser three times in order to multitask.  Strangely, after the page is finally completely rendered, there is no attempt to steal focus again.

Reproducible: Always

Steps to Reproduce:
1.On the N800 with OS2008, use the web menu to select a bookmark.
2.Minimize the browser while the page loads.
3.Wait.  Browser will maximize.
4.Minimize the browser.
5.Wait.  Browser will maximize.
6.Minimize the browser.
7.Wait.  Check on browser and see the fully rendered page.


Expected Results:  
Applications should not steal focus.  Ever.
http://www.codinghorror.com/blog/archives/001011.html
(Reporter)

Comment 1

9 years ago
My mistake - was misinformed that the default browser was somehow associated with Firefox.  Feeling pretty dumb now that I have installed Fennec, today.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 2

8 years ago
sorry for bug spam.
Many of the bugs which are marked invalid, I see comments telling it occurred in one version or other. But later it was fixed due to 1) by backingout the patch which made regression or 2) by fixing some other bug.
So if we can identify the bug/patch/reason then we should state that and mark those as FIXED. If not mark as WORKSFORME in that case.
verified Invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.