Closed Bug 483744 Opened 12 years ago Closed 12 years ago

Input type="file" with style="width:100%;" is broken

Categories

(Firefox :: General, defect)

x86_64
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: vegard, Unassigned)

Details

User-Agent:       Opera/9.63 (Windows NT 6.0; U; en) Presto/2.1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nb-NO; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

In firefox <input type="file" style="width:100%;"> ignores width 100%. Leaving width at 100% or any other value with % is equal to blank.

Reproducible: Always

Steps to Reproduce:
Create a html page with <input type="file" style="width:100%;">
Actual Results:  
Nothing

Expected Results:  
The input should stretch across the screen
input[type="file"] has only very limited support for author styling. see bug 52500.

You can still adjust the width using the size attribute on the input element.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: input[type=file]
You need to log in before you can comment on or make changes to this bug.