Password manager for site with & without "www"

RESOLVED DUPLICATE of bug 249115

Status

()

RESOLVED DUPLICATE of bug 249115
10 years ago
10 years ago

People

(Reporter: karthik167, Unassigned)

Tracking

1.9.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

I login to irctc.co.in site either as "http://irctc.co.in" or "http://www.irctc.co.in". Is it possible to make the password manager use/prompt the same password for both the sites rather than manually duplicating the entry for with and without "www".

Reproducible: Always

Steps to Reproduce:
1.Save password to site "http://irctc.co.in" in the passwd manager
2. Login to site "http://www.irctc.co.in"
3. Password manager doesnt prompt for password
Actual Results:  
Password manager doesnt prompt for password

Expected Results:  
Password manager prompts the password stored for "http://irctc.co.in"
Component: General → Password Manager
Product: Firefox → Toolkit
QA Contact: general → password.manager
Version: unspecified → 1.9.0 Branch
Unfortunately, www.site.com and site.com have to be treated as separate authentication domains.

The solution here is to either use server redirects (so a user going to site.com ends up at www.site.com, or vice versa), or to support wildcarding in the browser so that a user can let it know that separate domains should be treated equivalently. Which is what bug 249115 is about.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 249115
You need to log in before you can comment on or make changes to this bug.