Gmail Compose - Send broke

VERIFIED FIXED in mozilla1.9.2a1

Status

()

defect
--
major
VERIFIED FIXED
10 years ago
2 months ago

People

(Reporter: marun2, Assigned: mrbkap)

Tracking

({regression, verified1.9.1})

Trunk
mozilla1.9.2a1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090316 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090316 Minefield/3.2a1pre

Latest Minefield build 20090316.

Gmail Compose Window. Have to hit on Send more than once or twice to get the message going. Doesnt happen in the first "Send" click. Works with IE7 and Opera normally

Reproducible: Always

Steps to Reproduce:
1. Gmail compose message
2. Hit send
3. Says working... but doesnt send. Click send again. Happens all the time. 
Actual Results:  
Send button not working in gmail compose

Expected Results:  
Work normally? 

Found yesterday, but I thought it is my network that is slow to load. But found that the same issue keeps occurring every time. And IE7 and Opera are handling Gmail compose fine
Can you reproduce this in safe-mode? http://support.mozilla.com/en-US/kb/Safe+Mode
And if reproducible in safe-mode, do you get the same result with javascript.options.jit.content to false? http://kb.mozillazine.org/About:config
Version: unspecified → Trunk
Reporter

Comment 2

10 years ago
I started Minefield in safe mode, and the issue still occurs.

I then turned javascript options jit content to false. Then it starts working fine. (while still in safe mode)
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
I can reproduce a bug, and that is the word "Loading" in the middle of the mailbox on top, even if the message is already sent. This is not due to JIT to true. It seems to break further actions, though.

Regression range appears to be:
 http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=610fe3c5e234&tochange=54030de86b9c
and I verified this a couple of times.
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM
Ever confirmed: true
Flags: blocking1.9.2?
QA Contact: general → general
same for deleting mails.
Severity: trivial → major
OS: Windows XP → All
Hardware: x86 → All
Reporter

Comment 5

10 years ago
Gmail tasks is broke too. It works in IE7. I am using Minefield 20090317 build
(In reply to comment #5)
> Gmail tasks is broke too. It works in IE7. I am using Minefield 20090317 build

see also: https://bugzilla.mozilla.org/show_bug.cgi?id=483740#c1
since the range in comment 3 is narrowed down more than mine, i dupe the other bug to this one - the cause is the same.

@L. Mohan Arun: would have been nice if you had mentioned this bug# in the other report.
Duplicate of this bug: 483740
Reporter

Comment 8

10 years ago
Ok I thought that bug is not getting noticed so I mentioned it here
Reporter

Comment 9

10 years ago
This is not the only thing that has broken. Sometimes I have to click n click on a particular mail in the inbox to open up. It says Loading... and still loading... at the top. Works fine with opera and IE7.

Comment 10

10 years ago
I click on a label, then a threaded message and the threaded messages don't expand
Reporter

Comment 11

10 years ago
yes, the Expand All is not working also, sometimes it works, sometimes does not. Need to click on that more than once, and reload the page, to get it to happen. Keeps saying :"Loading" but doesnt do anything after that
Ben Turner, 
could you please check which of your checkins caused this ?
This bug is preventing people to use builds older than those from the 20090313 because Gmail has become pretty much useless.
I would expect bug 480185 is the most likely, can anyone verify?
Duplicate of this bug: 484253
(In reply to comment #10)
> I click on a label, then a threaded message and the threaded messages don't
> expand

I confirm this as well.   This is only on trunk and not branch.  gmail is a major site, please block for this.

Comment 16

10 years ago
(In reply to comment #13)
> I would expect bug 480185 is the most likely, can anyone verify?

Do you have a try-server build we can test?
Flags: wanted1.9.2?
Ok, I've narrowed it down to mrbkap's attachment 366684 [details] [diff] [review] from bug 480185. Reverting that alone fixes this bug. Debugging gmail sucks.
Reporter

Comment 18

10 years ago
Hi great, so gmail now works with Minefield latest build? Pls confirm so I can install Minefield nightly again. I had to uninstall MF and use the FF 3.1 b 3 because gmail was broke
Clearly a blocker.
Flags: wanted1.9.2?
Flags: blocking1.9.2?
Flags: blocking1.9.2+

Comment 20

10 years ago
(In reply to comment #18)
> Hi great, so gmail now works with Minefield latest build? Pls confirm so I can
> install Minefield nightly again. I had to uninstall MF and use the FF 3.1 b 3
> because gmail was broke
I don't think anything has been done yet with Trunk (Minefield) itself. There still needs to be a decision made as to what to do next. That may be backing out the item mentioned in Comment 17, redoing that patch, applying a new patch, or something else still to be determined.
Flags: blocking1.9.2+ → blocking1.9.2?
Shaver, Ray accidentally removed your blocking+. Please restore.
Posted patch PatchSplinter Review
There were two problems here:
  * The wrong patch from bug 480185 landed and...
  * The API that the patch that was supposed to land used was mildly broken.

This patch takes care of both of those problems.
Assignee: nobody → mrbkap
Status: NEW → ASSIGNED
Attachment #368593 - Flags: superreview?(jst)
Attachment #368593 - Flags: review?(jst)
Attachment #368593 - Flags: superreview?(jst)
Attachment #368593 - Flags: superreview+
Attachment #368593 - Flags: review?(jst)
Attachment #368593 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/61440f2eb1f5
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090320 Minefield/3.6a1pre ID:20090320154408

VERIFIED/FIXED on Windows
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090322 Minefield/3.6a1pre ID:20090322035551 too.
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.9.2a1

Comment 26

10 years ago
Verified with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090323 Minefield/3.6a1pre ID:20090323031543

Was previously able to consistently reproduce (reporter of bug 484253, a dupe of this), and now appears fixed on Linux.
Attachment #368593 - Flags: approval1.9.1+
Comment on attachment 368593 [details] [diff] [review]
Patch

Approving for 1.9.1 as this blocks mrbkap from merging his fix for bug 475864.
Verified on 1.9.1 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090511 Shiretoko/3.5b5pre ID:20090511031352
Flags: blocking1.9.2?
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.