formhistory.sqlite grows to 4GB in size

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: paulg, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.64 (X11; Linux i686; U; en) Presto/2.1.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7


We have about 1151 undergrad home directories on our NFS fileserver, along with grads and faculty. After a user reported issues with FF3 we notices that the user had a 4GB formhistory.sqlite file.

We have found 9 users with 4GB size files on our systems.

Help!

Reproducible: Couldn't Reproduce
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Updated

10 years ago
Component: File Handling → Places
QA Contact: file.handling → places

Updated

10 years ago
Component: Places → Form Manager
Product: Firefox → Toolkit
QA Contact: places → form.manager
Version: 3.0 Branch → 1.9.0 Branch
Uhm, wow. 4GB?

Any possibility one of those users would be willing to (privately) share their form history DB, so we can see what's going on? Alternatively, I can try working with one of them to gather data/statistics remotely, but that's going to be harder and take longer.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Uhm, wow. 4GB?
> 
> Any possibility one of those users would be willing to (privately) share their
> form history DB, so we can see what's going on? Alternatively, I can try
> working with one of them to gather data/statistics remotely, but that's going
> to be harder and take longer.

One of our users are willing to privately) share their form history DB.  Can you let me what is the best way to this file to you. I
(Reporter)

Comment 3

10 years ago
jaxx 322 % ls -l
4294966272 Mar 16 11:07 formhistory.sqlite
     19734 Mar 16 11:07 formhistory.sqlite.bz2

Looks like a lot of empty space to me! The file formhistory.sqlite is the original file and the .bz2 file is what I get after I ran the command 
'bzip2 --keep formhistory.sqlite'
Oh, good, it compresses. :) Can you just email it to me -- dolske@mozilla.com.

Might you also be able to confirm that the other other 4GB files compress similarly? That would help confirm that they're all encountering the same issue.
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> Oh, good, it compresses. :) Can you just email it to me -- dolske@mozilla.com.
> 
> Might you also be able to confirm that the other other 4GB files compress
> similarly? That would help confirm that they're all encountering the same
> issue.

I have e-mailed the file to you. I was able to compress one of the other 4GB file and it compressed to just 7K.
Hmm, I seem to have forgotten to update this bug, at least twice now. :/

The zipped DB was only notable for having a gigantic sequence of nulls appended to the end, and didn't seem otherwise corrupt. No idea how that happens, or what else to do with this bug given that there don't seem to be any other reports of this happening.

You should be able to fix the problem by just using the command line sqlite3 utility to issue a VACUUM command to the DB.

Comment 7

3 years ago
reporter writes "No one seems to have any issue since 2009.", including reporter.
so => WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.