Crashed when browsing twitter - with Greasemonkey script

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: srinivasgundelli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)

The Tab froze all the open Firefox browser window after I opened twitter.com while scrolling the page down with arrow keys on keyboard which made the page and other open windows freeze.

Reproducible: Sometimes

Steps to Reproduce:
1.Install grease monkey script - troy's twitter script
2.Open twitter.com (login and go to Home(header link)
3.Scroll till the end of the page. Wait. try scrolling with the arrow keys
Actual Results:  
The above steps were performed exactly after Firefox 3.1 beta 3 was installed on Windows Vista. The browser window froze for 40 seconds to 1 minute and came back to its initial state

Expected Results:  
Not frozen the windows instead, only the tab should had been frozen for other tabs/ open windows to keep running independantly on their own

I was using the default Mozilla theme with ADD-ons: Yahoo toolbar 1.6.5.200812101546, WikiLook 1.3.7, Veoh Web Player 1.4, Ubiquity 0.2pre17, RealPlayer Browser plugin 1.0, Personas 1.0.b4, Operator 0.9.3, Objection 0.3.3, Microsoft .NET Framework Assistant 1.0, is.gd Creator 0.2.2, Greasemonkey 0.8.20090123.1, Google notebook 1.0.0.22, Google Gears 0.5.4.2, Evernote Web Clipper 3.0.0.128, DownThemAll 1.1.1, Diigo Bookmarks 3.1.6.13, Delicious Bookmarks 2.1.018, Auto Dial 6, Aging Tabs 0.7.1,
Firefox is running as single process and if one script maxes out the CPU, all tabs are hanging.

marking ivnalid because this is caused by a third-party addon
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Well the process per tab bug will semi enhance the experience here, but this is still an invalid bug per comment 1.

v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.