part of the persona's header image shines through the background of the "All in one Sidebar"

RESOLVED FIXED

Status

defect
P2
trivial
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: kkjarzyna, Assigned: cbeard)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.7) Firefox/3.0.7

On every themes thats did.

Reproducible: Always
This probably affects other sidebars too, and we should come up with a general solution for this.  In the meantime, reporter: you should also report it to the author of the All in One Sidebar, as they can probably fix this in their sidebar (by giving it a background color).

Updated

10 years ago
Priority: -- → P2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Some part of addon "All in one Sidebar" don't hace a background it means a color from Personas's theme. → part of the persona's header image shines through the background of the "All in one Sidebar"
(Reporter)

Comment 2

10 years ago
I send at this moment a email to All in One Sidebar author. 

I put there a screenshot and url to this Bugzilla problem.
(Reporter)

Comment 3

10 years ago
I get this message from author of this addonn:

"Hello XXX,

first excuse me for the late answer.

Thanks for reporting this. Normally I could do nothing in this part, because Personas didn't support vertical toolbars. It would be a very bad solution to add just a background-color (as suggested at Bugzilla), because ...

    * ... every theme of Personas would need a different color
    * ... Personas uses background-images, and even different background-colors wouldn't look nice, because of the missing image

However, I will have a look into this. But I don't think that I can fix this. :-(

Best regards
Ingo

-- 
http://firefox.exxile.net
I think Ingo might misunderstand.  I wasn't suggesting that the All in One Sidebar chrome should match the Personas background, only that it should specify its own background so the Personas background doesn't bleed through.

I took a closer look at this, and there are actually two issues here.  One issue is that Personas makes all toolbars transparent, no matter where they are in the window.  So it makes the All in One Sidebar's vertical toolbar transparent as well, even though it shouldn't (it should only make the horizontal toolbars in the main toolbox at the top of the screen transparent).

I fixed that in changeset http://hg.mozilla.org/labs/personas/rev/a5266a4f3ef7.

Nevertheless, that doesn't completely fix the problem, because even without Personas, All in One Sidebar makes its own toolbar transparent by setting -moz-appearance: none on it and then not specifying a background color.  To completely fix this, All in One Sidebar should specify a background color for the toolbar.

Resolving this bug, as the Personas side of this is fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 5

10 years ago
Dear Myk,

actually I misunderstood you. Now it's fixed and Personas didn't theme the AiOS toolbar and the sidebar elements. But my idea was, that Personas should theme the complete browser, including sidebar elements which are not themed at present - even without AiOS. I think this is what users expect to get.

Just my two cents: this could be done by defining an additional background-color. Designers could fade out their image to a specific color. This color could be used for the rest of the browser window. What do you think about this idea?

Best regards
Ingo
Ingo: I agree and think your suggestion is a great idea!  Note that the version of Personas that has been incorporated into Firefox 3.6 uses the accent color as the background color for the whole window, so transparent chrome (like the splitter between sidebars and the main content pane) gets that color as the background color.

If your sidebar is also transparent, then that background color should also be the background color for your sidebar.  And if personas designers then design their personas to fade to that color, then the sidebar's background should look really good!  This has been filed as bug 520999, and I've suggested we make it a high priority for the next release of the extension.

Another thing we can do to make things better, even if designers don't update their designs to fade to the accent color, is to shrink the persona image to the height of the toolbars.  I filed that as bug 528347 and suggested we make it a high priority for the next release of the extension as well.

Comment 7

10 years ago
Very good news! :-D 

I will immediately begin to make the remaining parts of AiOS transparent.

Thanks.
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.