Closed Bug 484051 Opened 12 years ago Closed 12 years ago

Please QA and Sign the Funnelcake07 Repack (3.0.7)

Categories

(Release Engineering :: Release Requests, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kkovash, Assigned: kev)

References

()

Details

Please start the QA review process on the Funnelcake version 7 partner
distribution of Firefox.

The repack worksheet is located at:

https://intranet.mozilla.org/Firefox:Distribution:Funnelcake

Changes to the Funnelcake build are the AUS channel is incremented to mozilla07
and the argument to the firstrun and update page is incremented to "f=7".

3.0.7 installers are available from their respective locale directories at:

https://people.mozilla.com/files/partners/mozilla07/3.0.7/

Please contact Kev if you require the uname/password, or if there
are any questions related to this distribution.
Blocks: 484055
taking !
Assignee: nobody → cbook
(In reply to comment #1)
> taking !

oh ok per email conversation we need to have builds that include the feedback, so waiting for new builds.
tomcat: installers are ready at the location above. very large thanks to nick for working this one out. creating an installer where files are replaced ad hoc is... a learning experience. :)
(In reply to comment #3)
> tomcat: installers are ready at the location above. very large thanks to nick
> for working this one out. creating an installer where files are replaced ad hoc
> is... a learning experience. :)

thanks ! starting Testing !
My method (ftr):
* on fx-win32-1.9-slave2, the 3.0.x release box
* Download en-US vanilla exe and unpack with 7z
* copy in signed setup.exe I created earlier, and nonlocalized/distribution/ (from kev)
* combine all application files with
 7z a -r -t7z ../new_parts/app.7z -mx -m0=BCJ2 -m1=LZMA:d24 -m2=LZMA:d19 -m3=L
ZMA:d19  -mb0:1 -mb0s1:2 -mb0s2:3
* copy self extraction binary from 3.0.7 build
 cp -p /e/fx19rel/WINNT_5.2_Depend/mozilla/obj-fx-trunk/browser/installer/wind
ows/instgen/7zSD.sfx
* copy app.tag from the same dir
* combine the three parts into the installer
 cat 7zSD.sfx app.tag app.7z > ../'Firefox Setup 3.0.7.exe'

Checks:
* new Funnelcake installer is 7471304 bytes, 45344 smaller than the equivalent unsigned vanilla intaller, but
 * unpacking both with 7z and diffed, reports only setup.exe and distribution.ini as expected
 * installer works fine on my XP VM
So it appears to be OK, and the changes to the files may have allowed slightly better compression (0.6%).
We did all this because '7za u' (to update files in an archive) reports 'Not implemented' - perhaps because we're using the default solid archives for 7z, which groups files together for better compression. The partner repacks have been using '7za a' to add files.
Status: NEW → ASSIGNED
Note, we have now a Problem here - on the Windows (XP) Testrun when i cancel the Installer, i get the question if i want to give feedback (as expected) BUT whatever i choice yes/no - i get no feedback from.

So is this a general bug, or did we forget to include this feedback forms ?
(In reply to comment #7)
> Note, we have now a Problem here - on the Windows (XP) Testrun when i cancel
> the Installer, i get the question if i want to give feedback (as expected) BUT
> whatever i choice yes/no - i get no feedback from.
> 
> So is this a general bug, or did we forget to include this feedback forms ?

so digged into this, and found the reason for the fail, we depend on a default browser here and since i had installed firefox first and uninstalled this, i had no default browser.
With IE (or any browser set as default) the test pass 

also its a known bug :
https://bugzilla.mozilla.org/show_bug.cgi?id=352787
https://bugzilla.mozilla.org/show_bug.cgi?id=255225

sorry for the false alarm :/
Tests pass and results are here https://intranet.mozilla.org/Firefox:Distribution:3.0Funnelcake:3.0.7Test_Results - also feedback works

Build is ready for signing
Assignee: cbook → kev
assuming the build that was tested was people.mozilla.com:/tmp/Firefox Setup 3.0.7.exe - tomcat, can you confirm and I'll bundle everything for signing?

thanks folks!
Funnelcake 07 repacks are ready for signing in:

people.mozilla.com:/tmp/funnelcake07-307-unsigned.tar

md5sum of the tarball is a2acd66adf0fcaab8ddf5114a73d30db
Assignee: kev → nobody
(In reply to comment #10)
> assuming the build that was tested was people.mozilla.com:/tmp/Firefox Setup
> 3.0.7.exe - tomcat, can you confirm and I'll bundle everything for signing?
> 
> thanks folks!

yup confirmed that build was tested and pass the tests !
Assignee: nobody → nthomas
Priority: -- → P2
now signed at

people.mozilla.org:/tmp/funnelcake07-signed.tar

md5sum for the file is 822b7556a38f13f3727dd42d7031c920

Over to Kev.
Assignee: nthomas → kev
Priority: P2 → --
repacks extracted and available at:

https://people.mozilla.com/files/partners/mozilla07/3.0.7/ (or using the tarball in comment #13).

authentication credentials are the same as previous funnelcake repacks, please let me know if you need them.

good to go.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Component: Release Engineering: Custom Builds → Release Engineering: Releases
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.