Search does not return defect when search string and title refer to OS

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Henk, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506)
Build Identifier: v3.2.2 - stable

When a defect summary contains the word 'MAC', it will not pop-up in the search results when searching for this specific word. Searching for other words in the same summary does work fine.
Analysis: It seems that when the title refers (partially) to an OS it skips these defects when searching for this particular word. Besides MAC, I confirmed this applies as well to 'Linux'.
  Example: a defect exists with summary: "CM MAC bla"

When performing a search on MAC on the above defect, Bugzilla will not find it.

Reproducible: Always

Steps to Reproduce:
Precondition: Defect exists with a title as mentioned above
Steps:
1.Enter CM  in the search box and see if it is returned in the results
2.Enter bla in the search box and see if it is returned in the results
3.Enter MAC in the search box and see if it is returned in the results
Actual Results:  
1.OK  - the defect is listed
2.OK  - the defect is listed
3.NOK - the defect is not listed

Expected Results:  
The defect is listed on all 3 occasions.

I actually assume this problem is already reported, but I couldn't find it after several searches... If it turns out to be a duplicate, please reject it.

Comment 1

9 years ago
Advanced Search is able to find it. When you use the Specific Search, it probably ignores MAC because this word is either too common and rejected by MySQL's fulltext search engine, or because this word is in the stopwords list of MySQL.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 2

9 years ago
Oh, and looking for "Linux" works fine. Bugs are correctly reported, so it's unrelated to OSes.
(Reporter)

Comment 3

9 years ago
[1] 
At the moment I disagree on your statement regarding Linux. Please see:
https://landfill.bugzilla.org/bugzilla-3.2-branch/show_bug.cgi?id=7170

This defect has title "Linux MAC bla".

=> Doing quicksearch on Linux will not return this defect
=> Doing quicksearch on MAC   will not return this defect

[2]
I couldn't find the word MAC in the stop word list:
http://dev.mysql.com/doc/refman/5.1/en/fulltext-stopwords.html

Besides, I tried to search for several of these "stopwords", but they actually work... so I don't really follow what are the criteria for displaying or not displaying them. I expected a 100% fail on each word - if they really are "stopwords" in the literal sense.

[3]
Question : this list of Stopwords, is there another list that indicates the "forbidden" common words you refer to ?
Question 2: Why is it when searching on a word from the Summary, the quicksearch returns different results compared to the Advanced ? Shouldn't it use the same algorithm (Quicksearch also searches the description, so it should be even a superset)?
You need to log in before you can comment on or make changes to this bug.