Closed Bug 484124 Opened 11 years ago Closed 11 years ago

geolocation keybinding should be changed

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 491769

People

(Reporter: dougt, Assigned: dougt)

Details

Attachments

(1 file)

In bug 483845, we modified the strings we used for the geolocation prompt.  After looking at it some, the keyboard shortcuts were wrong and we believe we should change them to:

t -- Tell them  (the accept button)
d -- Don't tell them (the deny button)
Attachment #368178 - Flags: review?(mconnor)
mconnor/gavin, patch tested on mac,win32,linux/gtk.
OS: Mac OS X → All
Hardware: x86 → All
alt+d works for bookmarking pages... how does this interact?
Also, if you're using capital letters, set the accesskey to be the capital letter.  match case always, please.
on windows, ctrl+d == bookmarks.  alt+d doesn't seem to do anything when the geolocation prompt isn't present.

I can match the case.  Is there anything else I should test?
tested on IRC, alt+D focuses the location bar, alt+T opens the tools menu, so this patch isn't ok.
i am open to suggestions.
new access keys landed as part of 491769.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491769
Attachment #368178 - Flags: review?(mconnor)
You need to log in before you can comment on or make changes to this bug.