Extensions don't load as expected

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: brianjdoherty, Assigned: mfinkle)

Tracking

Trunk
Other
Other

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Fennec Beta 1

I installed Fennec Beta 1 on a stock Nokia N810.  When I tried to install an extension (Gestures), it asked me if I want to load the xpi file in the web browser, or save the file.  When I choose browser, it tries to open the xpi file in the system's default browser.  When I choose save, it doesn't seem to do anything.  Going to the download screen shows the file was downloaded, but clicking on it does nothing.  I'm sure I could find the xpi file in my filesystem, but I don't see a way to load an xpi file from the filesystem.  Also, the links in the initial Addons screen don't seem to work.  

Reproducible: Always

Steps to Reproduce:
1. Go to Extensions page in Mozilla.org (fennec-specific one), 
2. Choose an extension to install (e.g. Gestures), 
3. Dialog box appears - neither option acts as expected from Firefox experience. 
Actual Results:  
See Details above

Expected Results:  
Extension should install. 

I am surprised that this feature could be broken and no-one noticed for a beta product.  Alpha, maybe, but not beta.  Maybe it's me, but I can't figure out what I'm doing wrong.  Sorry if this is mis-using the bug system - I'm not a developer.
(Assignee)

Comment 1

10 years ago
I'm not sure what the actual XPI URL is you are trying to install. Can you provide it? If the "save file" dialog appears, it usually means the XPI is not being served with application/x-xpinstall mime type.

Installing from the add-on manager "Get Add-ons" works, for those add-ons on AMO.

I did notice that trying to install Gestures from bug 476425 attachment 368187 [details] (which is application/x-xpinstall), I got the notification bar warning (expected) and the "install add-on" dialog (expected) - but the add-on failed to install.

Turns out the problem was a bug in the code to show the Add-on Manager after the "install add-on" dialog was confirmed. Patch coming up for that.
(Assignee)

Comment 2

10 years ago
Created attachment 368249 [details] [diff] [review]
patch

After we confirm the add-on for install, we must show the Add-on Manager. The XPInstall listener in the Add-on Manager is used to start the download and complete the install.
Assignee: nobody → mark.finkle
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #368249 - Flags: review?(gavin.sharp)
(Reporter)

Comment 3

10 years ago
OK, this morning I did successfully add an Extension from the Add-on manager: AutoAuth.  What does not work is when I navigate to this URL and try to click on the Download link, e.g. for TwitterBar: 
https://addons.mozilla.org/en-US/fennec/ 
That's when I get the dialog box asking me to choose between opening the XPI file in the system default browser, or saving the file to disk.  Thanks for looking into this.  The Fennec browser is a little sluggish on my N810, but still fun to use because it's finger-friendly and has an appealing look.  BTW, the dialog box I mentioned above looks a bit odd - it does not match either Fennec or the systems's theme.
(Assignee)

Comment 4

10 years ago
I should note that when we move Add-on Manager directly into browser.xul, instead of displaying in an iframe, we won't technically need to display the add-on manager to finish the install.

But we might want to anyway, just as a visual confirmation to the user that something is happening.
Attachment #368249 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 5

10 years ago
http://hg.mozilla.org/mobile-browser/rev/338f342ecf0a
http://hg.mozilla.org/mobile-browser/rev/9435ee77dda3 spelling fix
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
addons are working pretty well the last few months.  Verified with beta3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.