Sending mail with large file attachment error, no antivir

RESOLVED INVALID

Status

MailNews Core
Networking: SMTP
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Andy, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: ThunderBird 2.0.0.19

I always get SMTP error message every time I send a mail with large file attachment file (+/- 800Kb PDF) even without AV protection, but no problem when sending mail with no attachment or with small size ( JPEG 100Kb ). 
This error occured after I use latest Thunderbird 2.0.0.19.
Sending it through Gmail-Webmail showed no problem at all.
To compare it I use OE, I can send 8Mb file smoothly. I guess its coming from TB, but not sure which parameters, been looking around TB forums but couldn't find one similar solution to my problem.

Reproducible: Always

Steps to Reproduce:
1.Just compose/write mail/forward , put attachment on it at least 800Kb file
2.Send it, and I get sending progress bar message
3.The progress bar will go up till it reach 100%, and then failed message appears, SMTP error.
The STMP server is GMAIL, SSL 465 or TLS 25 gives same result.
Repeat the procedure by disabling my AV and Malwarebytes program, but same thing occured.
Additional step, send mail with no attachment will be ok, no error message.
Actual Results:  
This error message happened all the time, no matter what setting I set.
Server type,Ports setting, password, username, time delay, etc

Expected Results:  
It should be a normal succesfull delivery message and the mail will reach the appointed address as in the old version does.

I use ADSL connection ( this shouldn't be a problem ), AV NOD32 Smart Security version, MalwareBytes, XP SP3

Look forward, for any assistance regarding this problem, Thanks
Andy can you follow the instructions at https://wiki.mozilla.org/MailNews:Logging and provide us with an SMTP log so we can figure out what is going on.
Component: General → Networking: SMTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

9 years ago
Below are the logs taken from 2 times failed sending message, hope this help
Thanks

0[34778]: SMTP Connecting to: smtp.gmail.com
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 220 mx.google.com ESMTP 28sm3152093wfd.45
0[34778]: SMTP entering state: 15
0[34778]: SMTP Send: EHLO [127.0.0.1]

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-mx.google.com at your service, [118.136.67.198]
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-SIZE 35651584
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-8BITMIME
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-AUTH LOGIN PLAIN
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-ENHANCEDSTATUSCODES
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 PIPELINING
0[34778]: SMTP entering state: 4
0[34778]: SMTP entering state: 22
0[34778]: SMTP entering state: 17
0[34778]: Logging suppressed for this command (it probably contained authentication information)
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 235 2.7.0 Accepted
0[34778]: SMTP entering state: 19
0[34778]: SMTP entering state: 3
0[34778]: SMTP Send: MAIL FROM:<andy.sartono@gmail.com> SIZE=2074622

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.1.0 OK 28sm3152093wfd.45
0[34778]: SMTP entering state: 6
0[34778]: SMTP Send: RCPT TO:<a55ihh@yahoo.com>

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.1.5 OK 28sm3152093wfd.45
0[34778]: SMTP entering state: 7
0[34778]: SMTP Send: DATA

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 354  Go ahead 28sm3152093wfd.45
0[34778]: SMTP entering state: 8
0[34778]: SMTP entering state: 9
0[34778]: SMTP Send: .

0[34778]: SMTP Connecting to: smtp.gmail.com
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 220 mx.google.com ESMTP 24sm3214324wff.2
0[34778]: SMTP entering state: 15
0[34778]: SMTP Send: EHLO [127.0.0.1]

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-mx.google.com at your service, [118.136.67.198]
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-SIZE 35651584
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-8BITMIME
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-AUTH LOGIN PLAIN
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-ENHANCEDSTATUSCODES
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 PIPELINING
0[34778]: SMTP entering state: 4
0[34778]: SMTP entering state: 22
0[34778]: SMTP entering state: 17
0[34778]: Logging suppressed for this command (it probably contained authentication information)
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 235 2.7.0 Accepted
0[34778]: SMTP entering state: 19
0[34778]: SMTP entering state: 3
0[34778]: SMTP Send: MAIL FROM:<andy.sartono@gmail.com> SIZE=2074622

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.1.0 OK 24sm3214324wff.2
0[34778]: SMTP entering state: 6
0[34778]: SMTP Send: RCPT TO:<a55ihh@yahoo.com>

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.1.5 OK 24sm3214324wff.2
0[34778]: SMTP entering state: 7
0[34778]: SMTP Send: DATA

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 354  Go ahead 24sm3214324wff.2
0[34778]: SMTP entering state: 8
0[34778]: SMTP entering state: 9
0[34778]: SMTP Send: .
(Reporter)

Comment 3

9 years ago
This one taken from a succesfull send message with a small size attachment, 90Kb PDF file

0[34778]: SMTP Connecting to: smtp.gmail.com
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 220 mx.google.com ESMTP 22sm3251258wfg.3
0[34778]: SMTP entering state: 15
0[34778]: SMTP Send: EHLO [127.0.0.1]

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-mx.google.com at your service, [118.136.67.198]
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-SIZE 35651584
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-8BITMIME
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-AUTH LOGIN PLAIN
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250-ENHANCEDSTATUSCODES
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 PIPELINING
0[34778]: SMTP entering state: 4
0[34778]: SMTP entering state: 22
0[34778]: SMTP entering state: 17
0[34778]: Logging suppressed for this command (it probably contained authentication information)
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 235 2.7.0 Accepted
0[34778]: SMTP entering state: 19
0[34778]: SMTP entering state: 3
0[34778]: SMTP Send: MAIL FROM:<andy.sartono@gmail.com> SIZE=124348

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.1.0 OK 22sm3251258wfg.3
0[34778]: SMTP entering state: 6
0[34778]: SMTP Send: RCPT TO:<a55ihh@yahoo.com>

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.1.5 OK 22sm3251258wfg.3
0[34778]: SMTP entering state: 7
0[34778]: SMTP Send: DATA

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 354  Go ahead 22sm3251258wfg.3
0[34778]: SMTP entering state: 8
0[34778]: SMTP entering state: 9
0[34778]: SMTP Send: .

0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 250 2.0.0 OK 1237531747 22sm3251258wfg.3
0[34778]: SMTP entering state: 10
0[34778]: SMTP Send: QUIT

0[34778]: SMTP entering state: 0
0[34778]: SMTP entering state: 0
0[34778]: SMTP Response: 221 2.0.0 closing connection 22sm3251258wfg.3
0[34778]: SMTP entering state: 11
0[34778]: SMTP entering state: 13
(Reporter)

Comment 4

9 years ago
At this moment all logs were taken after upgraded TB version 2.0.0.21
(Reporter)

Updated

9 years ago
Severity: normal → major

Comment 5

9 years ago
references:
bug 449609 comment 1
bug 297487
Summary: Sending mail with large file attachment error → Sending mail with large file attachment error, no antivir
> The STMP server is GMAIL, SSL 465 or TLS 25 gives same result.

Google's instruction for SMTP is as follows. 
> http://mail.google.com/support/bin/answer.py?hl=en&answer=13287
> smtp.gmail.com (use authentication)
> Use Authentication: Yes
> Use STARTTLS: Yes (some clients call this SSL)
> Port: 465 or 587

Andy(bug opener), what is your purpose to use different setting from Google's instruction?

Note: Tb fortunately doesn't call STARTTLS SSL, but Tb 2 calls STARTTLS TLS in setting UI. (confusing/wrong "TLS" is already corrected to STARTTLS by Tb 3).
(Reporter)

Comment 7

9 years ago
I use SSL port 465 on my old TB but it didn't bring up this problem at all.
Probably its because of my laptop corrupted somehow, this things didn't happen
on my desktop which using similar system and configuration as in my lappy.
I will close this thread, as this error was caused by my corrupted lappy.

Thank you for all of your support and help, Wada, Wayne and Ludovic much appreciated it

Andy
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.