Update to thunderbird changed permissions to read-only during install

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: oms, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; SIMBAR={BE41B237-4FE8-409C-BB3D-AF8A64B6BCBF}; GTB5; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Thunderbird 2.0

Update to thunderbird changed permissions to read-only during install. Error message comes back saying permissions needed to be changed. Changed permissions on all of the folders and files from READ-ONLY. Installer changed them back prior to installing again.  It's in a loop and I can't open Thunderbird and it won't un-install either.

Reproducible: Always

Steps to Reproduce:
1.Install latest update
2.Select to install
3.
Actual Results:  
Install status window.
Then Error message.
Change permissions.
Install status window.
Then Error message.
ETC...
Oren are you admin on your machine ?
by update - do you mean the auto-update mechanism or an install on top of another tb ?

Do you also have the issue with Thunderbird 3.0b2 ?

Comment 2

10 years ago
I'm having similar issues. I had 2.0.0.<something> and got the usual "Thunderbird will restart after it installs updates" message. Except now it's hung in a permissions error loop. The only way to kill it is to the ctrl-alt-del program manager and kill the Thunderbird process. (not the user application, that just continues to loop). Thinking that perhaps the update was corrupt, I downloaded the latest 2.0.0.22 from Mozilla and that too has the same issues trying to install. "Lack of permission".

Now what?

Sigh...

Comment 3

10 years ago
(In reply to comment #2)
> I'm having similar issues.

I rebooted the system (XP Professional service pack 3) and brought it up in "Safe Mode". I got the same error message when I first started Thunderbird, but apparently it made another try and installing and worked that time. Annoying, but at least it's working again.

Jeff

Comment 4

10 years ago
(In reply to comment #3)
I found that the problem seems to be related to "mozMAPI32.dll" in the install folder under program files.  The installation routine makes a backup of the .dll named *.moz-backup.  I solved my problem by deleting the dll and renaming the backup file.

This has happened to me several times on several different machines with different updates(All WinXPPro sp3).  My suspicion is the dll is corrupted during the download some how - only a guess.  Anyway the fix above has worked every time so far.

Presently I have v2.0.0.21 running
> (In reply to comment #2)
> > I'm having similar issues.
> 
> I rebooted the system (XP Professional service pack 3) and brought it up in
> "Safe Mode". I got the same error message when I first started Thunderbird, but
> apparently it made another try and installing and worked that time. Annoying,
> but at least it's working again.
> 
> Jeff
This sound as an Logitech webcam issue.
Oren, Jeff and JMShine: do you have Logitech webcam installed too?
Whiteboard: closeme 2010-05-12
Version: unspecified → 2.0

Comment 6

9 years ago
Yes, I have logitech webcam installed, but only on one machine where I thunderbird installed.  I am running Thunderbird 3.6.3 now and haven't had a problem lately.
(In reply to comment #6)
> Yes, I have logitech webcam installed, but only on one machine where I
> thunderbird installed.  I am running Thunderbird 3.6.3 now and haven't had a
> problem lately.

Ok this is a know issue on installation of TB 2.0.
The workaround is under:
If TB is set as default email client in the Quickcam software, then Quickcam will not let Mozilla update the file: you must disable the webcam  and try again. Another approach is to rename the mozMAPI.dll file or to temporarily set Quickcam to use a different email program as default.

Then I close this issue as Invalid because related to another software.
Feel free to reopen it if I'm wrong... and thanks for feedback

;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Whiteboard: closeme 2010-05-12
You need to log in before you can comment on or make changes to this bug.