[OS/2] simplify test_os2.cmd

VERIFIED FIXED in mozilla1.9.2a1

Status

Testing
XPCShell Harness
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Walter Meinl, Assigned: Walter Meinl)

Tracking

({fixed1.9.1})

Trunk
mozilla1.9.2a1
x86
OS/2
fixed1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed1.9.1b4])

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.2a1pre) Gecko/20090319 Minefield/3.6a1pre
Build Identifier: 

After the js unittests are now invoked by a python rather than a bash script we can simplify our new test_os2.cmd. Moreover, we should think about moving it somewhere else, because testing/xpcshell is not appropriate anymore, in fact test_os2.cmd does now do anything else but running xpcshell tests.

Reproducible: Always
(Assignee)

Comment 1

9 years ago
Created attachment 368363 [details] [diff] [review]
v1

Peter, the patch attached has probably DOS line endings for now, as I'm not sure how to deal with it that the rexx script works, after a fresh checkout from the patched repository.
Anyway, when we decide to move the file somewhere else, I can adjust it if needed.
Assignee: nobody → wuno
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Version: unspecified → Trunk

Comment 2

9 years ago
Perhaps we can create a new dir build/os2, similar to build/unix where run-mozilla.sh is located.

As for the linebreaks, you can just run dos2unix (or a similar tool) on the patch file before uploading.
(Assignee)

Comment 3

9 years ago
Created attachment 368727 [details] [diff] [review]
symplify and move it

(In reply to comment #2)
> Perhaps we can create a new dir build/os2, similar to build/unix where
> run-mozilla.sh is located.
>
done 
> As for the linebreaks, you can just run dos2unix (or a similar tool) on the
> patch file before uploading.
I did it for the repositories sake, but when I tried to run it in the end I got the usual
     1 +++   ?PARSE ARG dist prog parm?dist = forwardtoback(dist);
REX0013: Error 13 running
E:\usr\src\hg\mozilla-central\build\os2\test_os2.cmd, line 1: Invalid
character in program
Attachment #368363 - Attachment is obsolete: true
Attachment #368727 - Flags: review?(mozilla)

Comment 4

9 years ago
Comment on attachment 368727 [details] [diff] [review]
symplify and move it

Yes, thanks, looks good.
Attachment #368727 - Flags: review?(mozilla) → review+

Comment 5

9 years ago
(In reply to comment #3)
> > As for the linebreaks, you can just run dos2unix (or a similar tool) on the
> > patch file before uploading.
> I did it for the repositories sake, but when I tried to run it in the end I got
> the usual
>      1 +++   ?PARSE ARG dist prog parm?dist = forwardtoback(dist);
> REX0013: Error 13 running
> E:\usr\src\hg\mozilla-central\build\os2\test_os2.cmd, line 1: Invalid
> character in program

Äh... I think you misunderstood, don't do that to the CMD file in the repo, just to the patch you create from it. The file bug484287_simplify_and_move_os2_testprog.patch that you uploaded still contains DOSish linebreaks... (You can also use the VIM editor or some other one that let's you choose linebreak style when saving.)
(Assignee)

Comment 6

9 years ago
You're right. But when I convert the whole patch to unix line endings and we diff the novel test_os2.cmd in the new build/os2 location against dev/null, won't it then be unixish when we check it out again?
I could as well separate out the test_os2.cmd file (as I did in the former bug426639) and change the line endings only for the config.mk files and the removal of the old test file.

Comment 7

9 years ago
No, the repo itself is fully unixish. I don't know how you get DOS-like linebreaks (I use the hgext.win32text extension of Mercurial to only convert CMD files, as described at https://developer.mozilla.org/index.php?title=En/OS%2F%2F2_Build_Prerequisites/Building_on_OS%2F%2F2_using_Mercurial#section_2), but it has to be something that is done locally at your machine in any case. Patches have to be _fully_ unixish, because people who care for "checkin-needed" are unlikely to use any kind of linebreak transformation on their machines, and the patch will otherwise plain fail to apply for them.
(Assignee)

Comment 8

9 years ago
Created attachment 369105 [details] [diff] [review]
simplify and move it unix linebreaks
[Checkin: Comment 9 & 11]

same patch converted to unixish line endings
Attachment #368727 - Attachment is obsolete: true
Attachment #369105 - Flags: review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Comment on attachment 369105 [details] [diff] [review]
simplify and move it unix linebreaks
[Checkin: Comment 9 & 11]


http://hg.mozilla.org/mozilla-central/rev/7d0100982df9
Attachment #369105 - Attachment description: simplify and move it unix linebreaks → simplify and move it unix linebreaks [Checkin: Comment 9]
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
(Assignee)

Updated

9 years ago
Blocks: 426639
(Assignee)

Comment 10

9 years ago
Created attachment 369874 [details] [diff] [review]
patch for c-c
[Checkin: Comment 12]

This is needed for c-c. Basically, its slightly modified https://bugzilla.mozilla.org/attachment.cgi?id=363788 that has gotten r+ in bug426639, but was not checked-in due to timing issues (the python rewrite of the test harness came across). From the original patch the rules.mk part was removed as a consequence of the python rewrite and the path to $RUN_TEST_PROGRAM in config.mk was adjusted to the new location.
Attachment #369874 - Flags: review+
(Assignee)

Updated

9 years ago
Whiteboard: mozilla1.9.1 attachment 369105, c-c attachment 369874
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Comment on attachment 369105 [details] [diff] [review]
simplify and move it unix linebreaks
[Checkin: Comment 9 & 11]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/eaed056cf5e7
Attachment #369105 - Attachment description: simplify and move it unix linebreaks [Checkin: Comment 9] → simplify and move it unix linebreaks [Checkin: Comment 9 & 11]
Keywords: fixed1.9.1
Whiteboard: mozilla1.9.1 attachment 369105, c-c attachment 369874 → [c-n: c-c attachment 369874] [fixed1.9.1b4]
Comment on attachment 369874 [details] [diff] [review]
patch for c-c
[Checkin: Comment 12]


http://hg.mozilla.org/comm-central/rev/9f79f18ab013
Attachment #369874 - Attachment description: patch for c-c → patch for c-c [Checkin: Comment 12]
Keywords: checkin-needed
Whiteboard: [c-n: c-c attachment 369874] [fixed1.9.1b4] → [fixed1.9.1b4]
Depends on: 482084
(Assignee)

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.