Get "Get "--This message was sent by Messenger 5.0" multiple times in body" multiple times in body

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P3
normal
VERIFIED WORKSFORME
20 years ago
10 years ago

People

(Reporter: lchiang, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Get "--This message was sent by Messenger 5.0" multiple times in body

1999040808 build
RedHat Linux 5.2

1)  Tasks | Messenger
2)  New message.  Address the message and enter a subject.  Send to yourself.
Leave the compose window open.
3)  New message.  (Notice that the compose window opens already addressed to you
with the previous subject)
4)  Send to yourself.

Notice in the terminal window that the content of the message just sent shows
two "--This message was sent by Messenger 5.0" entries.  Likewise when you
receive the message, you'll see two ""--This message was sent by Messenger 5.0"
entries.  Each time you compose/send a message in this session, the number of
times this entry shows up increases!

Seth says this is because of the bug where the compose window doesn't close.
However, to make mail messages look somewhat decent :-) until that bug is fixed,
we shouldn't tack on so many "-- This message..." entries.  The user has no way
to overwrite this.

(I can't try this on Windows right now - leaving soon.  Seth says he'll fix this
on Linux.  Peter, if this happens on Windows, can you file a bug against Win32?)

Comment 1

20 years ago
Okay I think I know what's going on here. Lisa, I only saw the duplicate text
show up in the first compose window (the one I left open). The new message was
still addressed to me, but it only contained one line of the text. However when
I sent the message I a body that had the multiple lines.

Seth I don't know if this is something we can fix or not. The problem is that we
have one editor app core per instance of messenger. When you bring up a compose
window, we create an editor app core and bind it to the compose window. When we
bring up a second compose window, we use the app cores manager to retrieve an
editor app core. Since one has already been created, it returns the first editor
app core.

Apparently an editor app core is the "view".

Adding kostello & sfraser to the cc list. Greg/Simon what should we do about
this? Should we be creating a new editor app core every time we bring up a
compose window? Or should we be going through the app cores manager like we are
now to look up for any previously exisiting editor app cores and using it.

(If this is indeed the solution, then it is a pretty trivial change to our xul
files to instantiate a new editor app core every time we bring up a new
message).

Comment 2

20 years ago
This sounds like the existing issus that the list of appcores is global. At some
point, this list will become a per-top-level-window list, at which point your
problem will disappear.

To get around the problem now, you might be able to generate unique names for
your editor appcores, and pass that unique name into the apprcore.Init() method.
Or you could just not user the appcoresManager to manage the appcore, and keep
it in a global JS variable.

Comment 3

20 years ago
fyi - little late but yes, this behavior does occur in the win32 Apriil 8
optimized build.
(Reporter)

Updated

20 years ago
Hardware: Other → All
Summary: Get "Get "--This message was sent by Messenger 5.0" multiple times in body" multiple times in body → Get "Get "--This message was sent by Messenger 5.0" multiple times in body" multiple times in body
Assignee: sspitzer → ducarroz
re-assigning this bug to Jean-Francois since he owns msg compose.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 5

19 years ago
worksforme

Comment 6

19 years ago
This problem still occurs in the April 27 Win32 and Linux builds (build id
1999042708).  There was no build released for April 28.  Need to wait for next
build before can verify.
(Reporter)

Updated

19 years ago
QA Contact: 4080 → 4109

Comment 7

19 years ago
Can not verify until Linux bug 5736 is resolved.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Bug 5376 has been resolved and verified.

Testing with the April 3 build on Win32, Linux, and PPC builds (1999050308), the
original problem has been resolved.  Verified as worksforme.

Note: On Mac, it takes a long time for Messenger to complete loading. There is
an existing bug 5855.  Once I got Messenger loaded on the Mac, I was able to
successfully receive new mail without having duplicate messages being
downloaded.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.