xpcom violates xpcom calling conventions

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

9 years ago
nsErrorService (via nsInt2StrHashtable) and nsCategoryManager don't use the XPCOM allocator to allocate return strings, while nsComponentManager doesn't use the XPCOM deallocator to free strings returned from XPCOM methods.
(Assignee)

Comment 1

9 years ago
Created attachment 368403 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #368403 - Flags: superreview?(benjamin)
Attachment #368403 - Flags: review?(benjamin)

Updated

9 years ago
Attachment #368403 - Flags: superreview?(benjamin)
Attachment #368403 - Flags: superreview+
Attachment #368403 - Flags: review?(benjamin)
Attachment #368403 - Flags: review+
(Assignee)

Comment 2

9 years ago
Pushed changeset 6be239399910 to mozilla-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Duplicate of this bug: 413831
(Assignee)

Comment 4

9 years ago
Created attachment 369929 [details] [diff] [review]
Overlooked some _Frees
Attachment #369929 - Flags: superreview?(benjamin)
Attachment #369929 - Flags: review?(benjamin)

Updated

9 years ago
Attachment #369929 - Flags: superreview?(benjamin)
Attachment #369929 - Flags: superreview+
Attachment #369929 - Flags: review?(benjamin)
Attachment #369929 - Flags: review+
(Assignee)

Comment 5

9 years ago
Comment on attachment 369929 [details] [diff] [review]
Overlooked some _Frees

Pushed changeset bd377cffab2c to mozilla-central.
(Assignee)

Comment 6

9 years ago
Created attachment 371249 [details] [diff] [review]
Overlooked some more _Frees

Sorry, but my detection is only as good as my code coverage, so as I increase coverage (in this case by running xpcshell tests) I get more detections...
Attachment #371249 - Flags: superreview?(benjamin)
Attachment #371249 - Flags: review?(benjamin)

Updated

9 years ago
Attachment #371249 - Flags: superreview?(benjamin)
Attachment #371249 - Flags: superreview+
Attachment #371249 - Flags: review?(benjamin)
Attachment #371249 - Flags: review+
(Assignee)

Comment 7

9 years ago
Comment on attachment 371249 [details] [diff] [review]
Overlooked some more _Frees

Pushed changeset 964349d0ad35 to mozilla-central.
You need to log in before you can comment on or make changes to this bug.