bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Blank Account Wizard dialog pops up everytime I launch or open a Mail Compose window

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Account Configuration
P2
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: johng, Assigned: scottputterman)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood-][nsbeta3+][PDTP2]HAVE FIX)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
PR2 build 2000080712, nscp brand, using pop

This did not happen at first, but now happens everytime I use mail.  When I
first launch mail, I get the Account Wizard dialog with buttons at the bottom
and nothing inside (blank - I'll attach a screen shot).  Everytime I open a mail
message in a separate window or reply to an email, I get the same thing.

So annoying and frequent that I haven't been able to use email for any length of
time without going nuts.
(Reporter)

Comment 1

18 years ago
Created attachment 12687 [details]
screen shot of blank account wizard dialog
(Reporter)

Comment 2

18 years ago
so annoying, nominating nsbeta3 and dogfood
Keywords: dogfood, nsbeta3
(Reporter)

Comment 3

18 years ago
I did not start seeing this problem until I did an xpinstall of a beta of an 
alphanumerica tool, so cc'ing pete@alphanumerica.com.  However, no one else who 
install their beta Theme Builder ran into any problems - but I was the only one 
using POP in mail at the time.

The install of the tool *may* have something to do with this problem, may not.

Comment 4

18 years ago
I doubt it John. Look at your install.log you shouldn't see any replaced files.
there.

But if you were using pop mail when you installed then maybe you should let the
xpinstall guys know about this. This could be a possible xpinstall bug?

PS. Please don't call the tool "beta". I think "alpha" is better. ;-)

pete

Comment 5

18 years ago
changing component
Assignee: mscott → alecf
Component: Mail Back End → Account Manager

Comment 6

18 years ago
*** Bug 48388 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Is this only in the branch? I don't see this in 2000081008 win98, although I 
notice the content portion of the wizard does remain white/blank a bit longer 
than usual (before loading).

Comment 8

18 years ago
What is your platform, John?  I'm wondering if we create a new profile on your 
system, what would happen?

I don't know if this would be a mail bug since you said that the problem did not 
occur when you first installed PR2 until you installed another product.  Can you 
give us a link to that other product?
QA Contact: lchiang → nbaca

Comment 9

18 years ago
Marking dogfood- unless we can get a QA reproducable case or have more people
seeing this.  John, have you tried nuking your profile and starting again?
Whiteboard: [dogfood-]

Comment 10

18 years ago
+ per mail triage, P2
kmurray sees this.  I think it may be from using the standalone window.  nbaca 
and/or fenella - can you coordinate and then work with johng or kmurray to 
reproduce this?  I don't think theme builder is involved since kevin doesn't 
have that installed, but we can double check.

Thanks.
Severity: normal → major
Priority: P3 → P2
Whiteboard: [dogfood-] → [nsbeta3+][dogfood-]

Updated

18 years ago
Keywords: mail2

Comment 11

18 years ago
I can't reproduce this stilll.. can we get more information? I noticed that
john's screenshot includes a green border on the wizard, which implies it was on
the PR2 branch. Can anyone reproduce this on the tip?

Comment 12

18 years ago
removing nsbeta3+ for reevaluation, because this can't be reproduced..

John, if you can look at your console (Tasks->Tools->JavaScriptConsole) and see
if you have errors there, that would be great.
Whiteboard: [nsbeta3+][dogfood-] → [dogfood-]
(Reporter)

Comment 13

18 years ago
I'm still reproducing this everytime I use Mail - makes it almost unusable.  And 
I still get it with every new build, including my current build 2000081608.

Furthermore, Jennifer Mulcaster is also getting this problem, and she never 
install any xpi stuff like I did (with the Theme Builder tool from 
Alphanumerica) so that is not related.  Todd Pringle also had the problem, but 
it mysteriously went away.

Attaching a screen shot of the console.  If that doesn't help, all I can suggest 
is that nbaca or alecf visit my computer.

*If* this problem can be reproduced, it does need to be fixed, so I think you 
should keep the nsbeta3+ that you used to have.
(Reporter)

Comment 14

18 years ago
Created attachment 13105 [details]
console when act wizard pops up
(Reporter)

Comment 15

18 years ago
Created attachment 13134 [details]
prefs file
(Reporter)

Comment 16

18 years ago
When we created a new profile, this problem did not happen.  

More data - may or may not be relevant:
> All people who have run into this problem that *I* know have also been 
switching themes.
> Seen this on Win 95 and Win 98, on POP and IMAP.
> The problem was also experience by tpringle, but the problem later "vanished". 
 Don't know what he did.
(Reporter)

Comment 17

18 years ago
This IS dogfood for POP users because it makes it sooooooooooooooo hard to use 
and we can't access mail any other way (others with this problem are just 
switching to 4.x).  I'm obnoxiously renominating dogfood (and jenm agrees).  *At 
least* mark it nsbeta3+, can't ship with this.
Whiteboard: [dogfood-]

Comment 18

18 years ago
selmer reproduced for me finally. thanks for the JS output, I think I know how
to reproduce it

Comment 19

18 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=47123 seems to be the cause of this 
per nbaca's findings.  She sees this after clicking on a news URL.

Comment 20

18 years ago
It appears that bug# 48438, 46408 and 47123 are all related:

- 8/7 build on NT4: I select a link in an email for a News URL (that I'm not
currently subscribed to) and the Account Wizard appears and it's blank
(completely white with no text except for the buttons on the bottom). This is
the problem that Jennifer Mulcaster is reporting.

- 8/18 build on NT4: I click on the same link and the Account Wizard opens to
the Identity panel where all the elements of the window appear. If you progress
through the dialogs they are actually for IMAP/POP. Cancel out of the Account
Wizard. Now double click onto a message, from your initial mail account, and the
Account Wizard dialog appears again, cancel out of the dialog and now you can
see the contents of the message.

Workaround: Open the prefs.js file, search for "valid". You will probably see an
entry referring to the news account that was unsuccessfully created. If it
states something like this

"user_pref("mail.server.server3.type", "nntp");
user_pref("mail.server.server3.valid", false);"

then change it to be "true". Now try opening mail again. This should help the
Account Wizard from launching each time you double click on a message.

Comment 21

18 years ago
Great detective work.  We should probably dupe some of these bugs so we end up 
with just one bug?
(Assignee)

Comment 22

18 years ago
*** Bug 49710 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
In 49710, I never ever saw a blank account wizard window.  All of my account
wizard windows were complete and functional.  The first time it showed up, I
even created a new account with it.

On the other hand, I also discovered the valid flag and deleted that account to
make the problem go away.

Comment 24

18 years ago
Putting on [dogfood-] radar.
Whiteboard: [dogfood-]

Comment 25

18 years ago
*** Bug 47123 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
*** Bug 46408 has been marked as a duplicate of this bug. ***

Comment 27

18 years ago
Reminder to check scenarios in bug# 46408 and bug# 47123 when verifying.

Comment 28

18 years ago
+, P2 per mail triage
Whiteboard: [dogfood-] → [dogfood-][nsbeta3+]
Target Milestone: --- → M18
(Assignee)

Comment 29

18 years ago
*** Bug 49707 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 30

18 years ago
Adding selmer and ducarroz to cc list.  selmer found that this was being caused 
by one of his accounts being marked invalid.  There seems to be 2 problems here.  
One is figuring out why the account is invalid. The other is that why only 
having one invalid account when you have many other valid ones forces the 
account wizard up in the compose window.
Until last Thursday, if you deleted your default account, you get an invalid 
account. 

Comment 32

18 years ago
I have answers to both your questions
1) when a news URL is run, an "invalid" account is created so that the user is 
forced to enter information about the account
2) any invalid account should make the account wizard pop up - that's the 
desired behavior

The real problem to solve is why the account wizard isn't pre-filling itself 
with the invalid news account so that the user can complete the wizard and use 
the news account.
Status: NEW → ASSIGNED

Comment 33

18 years ago
I _do_ have an account that was created using a news URL.  It's not the one that
was marked invalid.

I don't believe the second question is answered.  Why does account wizard come
up when we launch a _compose_ window?  It should only come up when we launch
mail itself.

Is it possible that any attempt to send a message causes all accounts to be
touched in some way that launches the wizard?

Am I just confused?

Comment 34

18 years ago
Ah... the issue there is that any time ANY mail window is open, we do the 
"invalid accounts" check.... the code does not distinguish what kind of window 
it is... I know that's not a great answer, but that's why the current behavior 
exists

Comment 35

18 years ago
I would be happy if we resolved this just by excluding the compose window from
launching the account wizard.  Better would be to only allow launching the
wizard on the first creation of a top-level mailnews window.

Comment 36

18 years ago
What if you choose to compose a new message from the browser but you don't yet 
have an account set up?

Comment 37

18 years ago
Right.  Hmm.

I guess what I'm looking for is that the compose window should not generate the
wizard unless it's unable to fulfill its current request.  If I try to compose a
message using a valid account it should be happy with that.  If I try it without
a valid account then the wizard is OK.

It doesn't seem like this should be difficult for the compose window to figure
out.  I suspect some low-level function is being overly generous in bringing up
the wizard.

Comment 38

18 years ago
the whole compose window issue sounds like a seperate bug/feature. I'll make 
news accounts created via news URLs work correctly, and we can deal with that 
RFE in another bug.

Comment 39

18 years ago
So, you believe you can eliminate all cases that would lead to this?  It's a
very serious usability issue when it happens.  The average user is not going to
know how to solve this.

Comment 40

18 years ago
*** Bug 50067 has been marked as a duplicate of this bug. ***

Comment 41

18 years ago
*** Bug 50236 has been marked as a duplicate of this bug. ***

Comment 42

18 years ago
Mozilla/5.0 (X11; U; Linux 2.2.16-3smp i686; en-US; m17) Gecko/20000807

i am experiencing the same problem, but with a slight twist.  i don't mind
canceling out of the dialog box when it appears (too much...), but now i need to
add a POP3 account...and when i ask it for a new account wizard, it is blank as
well.  thus, simply eliminating all the cases that would lead to this is not an
appropriate solution (as far as i can tell?)...even in a legitimate use of the
wizard, the problem occurs.  (for me, at least.)

i can provide more information if you would like it...but i would be interested
to know if people experiencing the bug under discussion get a blank window when
they specifically ask for the new account wizard as well.

Comment 43

18 years ago
*** Bug 50618 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 36661

Comment 44

18 years ago
Brian Teague: Please read my comments from 8/18/2000. The first item sounds like
the same problem you are reporting. Later builds display Account Wizard dialogs
with content, they are not blank.

Comment 45

18 years ago
PDT agrees this should be a P2 bug.  This sounds really painful when it happens.  
If only we could be sure it was really rare... we would have pushed it down... 
but too many dups to say that :-/.
Whiteboard: [dogfood-][nsbeta3+] → [dogfood-][nsbeta3+][PDTP2]
taking from alecf.  he's got enough nsbeta3+ bugs.
Assignee: alecf → sspitzer
Status: ASSIGNED → NEW
accepting.
Status: NEW → ASSIGNED

Comment 48

18 years ago
*** Bug 51340 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 49

18 years ago
I will look into this if that's ok.
Assignee: sspitzer → putterman
Status: ASSIGNED → NEW
(Assignee)

Comment 50

18 years ago
Index: resources/content/AccountWizard.js
===================================================================
RCS file: 
/cvsroot/mozilla/mailnews/base/prefs/resources/content/AccountWizard.js,v
retrieving revision 1.65
diff -c -r1.65 AccountWizard.js
*** AccountWizard.js	2000/09/07 11:33:08	1.65
--- AccountWizard.js	2000/09/09 01:16:40

*** 537,543 ****
          dump("Invalid account: Got " + accountData + "\n");
          
          // account -> accountData -> pageData
!         AccountToAccountData(firstInvalidAccount, accountData);
          AccountDataToPageData(accountData, pageData);
  
          gCurrentAccountData = accountData;
--- 540,546 ----
          dump("Invalid account: Got " + accountData + "\n");
          
          // account -> accountData -> pageData
!         accountData = AccountToAccountData(firstInvalidAccount, accountData);
          AccountDataToPageData(accountData, pageData);
  
          gCurrentAccountData = accountData;


This is the reason why news accounts weren't working. In this case accountData 
gets passed in as null and AccountToAccountData creates a brand new accountData 
and returns it.  But we were never receiving the return value.  

With this fix, you are able to complete the news account when clicking on the 
news url and when you do you never get bothered again.

But, if you cancel from this window then you will be asked to fill in account 
data the next time you bring up a compose window but it won't be blank.

Alec, does this look ok to you?

I'm thinking that this is probably enough. The one bad UI aspect of this is that 
there's nothing that mentions what news account you are doing this for until the 
2nd pane in the account wizard.

Do we need to go farther with this?

Comment 51

18 years ago
this looks good - thanks for taking care of this, I can't believe how simple it 
was. 

I have another bug for having a paragraph on this panel explaining why the panel 
was brought up, but it's long since been -'ed..
(Assignee)

Updated

18 years ago
Whiteboard: [dogfood-][nsbeta3+][PDTP2] → [dogfood-][nsbeta3+][PDTP2]HAVE FIX
(Assignee)

Comment 52

18 years ago
i fixed it so that you can now complete an account if there's no isp data.
Cancelling will still require that you complete the account the next time you
bring up something mail related, but at least you'll be able to complete it.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 53

18 years ago
Build 2000-09-13-06M18: NT4, Linux 6.0, Mac 9.04

The following scenarios were performed with the Modern skin and Password Manager 
having saved the passwords. This was necessary due to bug# 52459

NT4: OK
1. Open a news url from the Browser and progress through Acct Wiz (OK)
2. Select news url link from a Mail message, Cancel the Account Wizard, start 
Composer and Acct Wiz appears, progress through dialogs. Also able to add 
another type of account afterwards. (OK)
3. Select news url link from a Mail message, progress through Account Wizard, 
try and create another account (OK)

Linux and Mac (Can't completely verify since Acct Wizard's Identity panel keeps 
stating "Please enter your name" even though I've entered text. Possibley 
related to bug# 52459)(Can't use Classic skin due to bug# 52535)
1. Can open a News url from the browser and can read messages.
2. Can select a news url link in a mail message and read messages.
Depends on: 52459, 52535

Comment 54

18 years ago
Build 2000-09-15-06M18: NT4, Linux 6.0, Mac 9.04
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.