Closed Bug 484404 Opened 11 years ago Closed 11 years ago

migrating thunderbird accounts/preferences between NT, XP, Vista or Mac

Categories

(Thunderbird :: Migration, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 196119

People

(Reporter: checco, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.21022; .NET CLR 3.5.30729)
Build Identifier: 2.0.0.21 (20090302)

The unfortunate thing with migrating mozilla thunderbird (and firefox/sunbird) settings is they include absolute paths for profile data... so if i am migrating between NT (where profiles are stored under c:\windows\profiles\zzz), XP (c:\documents and settings\zzz) or Vista (c:\users\zzz), the settings do not work correctly... some files are XML or text and can be readily updated, but other cannot.  

I need a full agnostic export of accounts, addresses, settings, preferences and add-ons.  

Ideally, a great feature would be to offer "synchronize" of thunderbird (FF and sunbird) settings to a secondary location (archive, net storage) for easy retrieval -- perhaps offering an online synchronization service to support "thunderbird anywhere".

Reproducible: Always

Steps to Reproduce:
1. create thunderbird settings under NT (where user profile is c:\winnt\profiles\userA)
2. copy profile directory to another box with XP or Vista (where user profile is NOT c:\winnt\profiles\userA)
3. try to open thunderbird on second machine


Actual Results:  
Thunderbird will respond that it is already running and must be exited or the computer needs to be restarted.

Expected Results:  
Would like to see thunderbird start with settings copied over.

or thunderbird should be aware of the mismatch, and ask the user to "repair" the settings.
(In reply to comment #0)
> The unfortunate thing with migrating mozilla thunderbird (and firefox/sunbird)
> settings is they include absolute paths for profile data... so if i am
> migrating between NT (where profiles are stored under c:\windows\profiles\zzz),
> XP (c:\documents and settings\zzz) or Vista (c:\users\zzz), the settings do not
> work correctly... some files are XML or text and can be readily updated, but
> other cannot.  

Most settings store files in relative directories. Indeed, it is often very possible to use the same profile from both Linux and Windows with few minor problems (the worst issue I've run into is the permissibility of colons in Linux filenames).

> Actual Results:  
> Thunderbird will respond that it is already running and must be exited or the
> computer needs to be restarted.

That merely means you can't start up two instances of the program at once on the same profile--delete the lock file in the directory first. Completely different from what you think the error is.

In any case, the very few absolute directory stuff we have is stored in bug 196119.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 196119
You need to log in before you can comment on or make changes to this bug.