Last Comment Bug 48443 - under windows in classic skin, url entry background color wrong when using different system colors
: under windows in classic skin, url entry background color wrong when using di...
Status: VERIFIED DUPLICATE of bug 57429
[nsbeta3-]
: classic
Product: SeaMonkey
Classification: Client Software
Component: Themes (show other bugs)
: Trunk
: x86 Windows 2000
: P3 minor (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: Patty Mac
:
Mentors:
n/a
: 48010 (view as bug list)
Depends on:
Blocks: 46519 46613
  Show dependency treegraph
 
Reported: 2000-08-10 12:10 PDT by justin hugh daly
Modified: 2008-07-31 01:19 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description justin hugh daly 2000-08-10 12:10:19 PDT
build from 8/10
win2k
classic theme

to reproduce:

   o  change windows 'appearance' in the display control panel (plum is my fav)


results

   o  white backgroup area around a grey text area in the url entry box


it also looks like the scroll bar's not honoring the system color?
Comment 1 Stephen Walker 2000-08-10 16:01:47 PDT
*** Bug 48010 has been marked as a duplicate of this bug. ***
Comment 2 Stephen Walker 2000-08-10 16:14:45 PDT
woops i dupped the bugs wrong, the comment listed in 48010: 

In the Windows Classic skin, in box.css, the color for .box-toolbar-group should
be "window" rather than "white":

.box-toolbar-group
  {
    background-color      : window;
    -moz-border-radius    : 5px;
    padding               : 3px 2px 2px 3px;
    margin                : 0px 10px 0px 5px;
  }

should fix this bug. also css code should be added to make the textcolor be the 
system's textcolor, because otherwise someone with a black window background 
won't be able to see the text
Comment 3 Michael Ward 2000-08-14 20:48:50 PDT
This is partialy fixed, now changing the color changes most of the URL entry
box, but not all of it. Changing the font color does not do anything, but it
does change the color of the text on the menubar! Should this bug change into
"Any colors in classic skin that aren't correct"?
Comment 4 leger 2000-08-17 12:38:45 PDT
Adding classic keyword
Comment 5 Blake Ross 2000-09-06 18:51:09 PDT
specific to classic, -> themes
Comment 6 Michael Ward 2000-09-06 19:47:19 PDT
I will try to list all the parts of classic which don't conform to the standard
windows interface. First, the url box is mostly correct, but it has a white
border that looks odd when a different color scheme is applyed. Next, the menu
headings in the menu bar and the bookmarks button on the personal toolbar use
the color windows calls "window text" in the display control panel. Also, the
status indicator uses this color while it should use a color that the user has
chosen to go over the window. That looks like all there is, doesn't seem to hard
to fix, keep up the good work Ben!
Comment 7 Michael Ward 2000-09-06 19:50:03 PDT
nominating nsbeta3+ after reading bug 46613
Comment 8 Patty Mac 2000-09-11 14:37:51 PDT
Fixed in windows (2000-09-11-08-M18).
Comment 9 justin hugh daly 2000-09-12 06:50:57 PDT
are you sure? i still see the white background around a grey text entry box in
the same build (200091108).
Comment 10 Patty Mac 2000-09-12 12:02:20 PDT
Hi Justin,

Sorry that I mistake. Yes, the white backgroup area around a light yellow text 
area in the url entry box.

Steps to reproduce:

1. Launch the netscape 6 with the new build (2000-09-12-08-M18).
2. Go the Preferences, select Themes.
3. Select Classic under Themes.
4. Go to windows by selecting the control panel under the settings menu.
5. Open "Display"
6. Click the "Appearance"
7. Select "Plum (High Color)"under "Scheme"
8. Notice that the white backgroup area around a light yellow text area in the 
   url entry box. This only happens in Classic.
Comment 11 Timothy Cole 2000-09-14 11:06:57 PDT
Something related to be careful of while fixing this:  <EM>never</EM> leave the
text color as a default, while forcing the background color, or vice versa.

Some people (e.g. me) have desktop themes with things like black windows and
white text.  When the URL bar background is forced to white, but the system text
color (white) is used, it does not look so good.
Comment 12 Jacob Steenhagen 2000-10-20 14:00:34 PDT
Bug 57426 may be related to this... I'm not sure.
Comment 13 Joe Hewitt (gone) 2001-01-18 23:23:06 PST

*** This bug has been marked as a duplicate of 57429 ***
Comment 14 Diego 2001-01-21 17:44:26 PST
Verified dipe of bug 57429: "Win classic theme should support system colors"

Note You need to log in before you can comment on or make changes to this bug.