AMO exposes add-on to out-of-range Firefox appversion

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: ehume, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 - Build ID: 2009021910

Add-ons with a specified version range are being shown to Firefox appversions that are not within the minversion/maxversion ranges specified by the add-ons.

As a developer, I have been forced to make themes that are incompatible with prior Firefox appversions. I would like to present versions of my themes to alpha and beta users without confusing users of the current Firefox version. 

Last night I posted eleven themes (theme version 3.1) to AMO. These themes have a Firefox minversion 3.1b1pre and a Firefox maxversion of 3.5b4pre. When I did a preliminary test with Firefox 3.0.7, I saw only the current theme version (3.0.5). Later, I found that with Firefox 3.0.7 I am presented with the 3.1 theme version intended only for beta users instead of the 3.0.5 theme version intended for the non-developmental browser users.

Normal (non-developmental) users of Firefox are presented with theme versions that are incompatible with their current browser. Quite a turn-off for someone considering whether to install a theme.

Reproducible: Always

Steps to Reproduce:
1. Post a theme with a version range that does not include the current Firefox.
2. Wait for servers to be populated.
3. Visit the theme's page with a browser that is outside the theme's range.
Actual Results:  
Users of the non-developmental browser are presented with a version of the theme that is not compatible with their browser.

Expected Results:  
Users of the non-developmental browser should see the version of the theme that is compatible with their browser.

I have looked through my old Bugzilla files. All of the other bugs relating to this issue were specific to particular Firefox versions.

The work-around for users is to look at older theme versions. Not many users see that link, though.

I will have to withdraw the 3.1 version of my themes. I will leave up HiVis Large, since it is the least-downloaded of my themes.
(Reporter)

Comment 1

10 years ago
Created attachment 368690 [details]
Theme display of Aeon 3.1, as seen by Firefox 3.0.7

Aeon 3.1 has a minversion/maxversion range of 3.1b1pre to 3.5b4pre. Firefox 3.0.7 is out of range, and should not see this theme.
Dupe of Bug 317577, but leaving open for reconsideration.

Comment 3

10 years ago
> The work-around for users is to look at older theme versions. Not many users
see that link, though.

I can't confirm this: When you look at an add-on that's only available for a newer version of Firefox, you'll see an "an older version may work" link. When clicking, it takes you to the "all versions" page, which in turn suggests the latest version of the add-on still compatible with your current browser.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.